Dual screens & composition mode

I use an extra screen attached to my MBA which I use for editing in Composition Mode. Scrivener on the MBA is in full-screen mode in Corkboard view, meaning the top menu pops down when I hover the mouse up there. I select a document on the Corkboard, hit the Composition key in the menubar, or use the keyboard shortcut and the document appears in the second screen. So far so good. However, when I finish editing one document and close it (either hitting ESC key or keyboard shortcut Composition mode and then move the mouse to the top of the screen, then menu no longer pops down. The only way to ‘recover’ the menu is to CMD-TAB to another application and then back into Scrivener.

First, I want to thank you for showing me that full screen plus composition mode is possible! I was fiddling around with the composition mode settings earlier today so as soon as I read your post, I knew which setting you’d changed. You’ve made my week.

Second, I see similar behaviour, but if I click once anywhere on the full-screen app after I’ve exited composition mode, the menu pops down as usual. Sounds silly, but do you click on the app before you head for the menu?

No, it makes no difference in my case. I usually quit Composition mode (ie close document on the attached screen) and then click another document in the corkboard. Still no menu drop down. Curious then that you recover it. I have corkboard open in main app, no Binder and no Inspector although I’ve just tried it with both on view and that makes no difference. :confused:

I take it that nobody else using an extra screen can replicate this bug?

Oops, sorry - I took a note of this problem and placed it in my “to investigate” project file, but forgot to reply to say I had done so:

I’ll look into it before 2.5 and reply to this thread if I need further information.



For what it’s worth, I am able to reproduce this behaviour now in the 2.4.5 beta and 2.4.1 release. I am now using a 2011 15" MBP with the AMD Radeon HD 6770M graphics card. I mention this in case the problem has something to do with certain hardware configurations. When I posted my earlier comment I was using a late 2008 15" MBP with NVIDIA GeForce 9600M GT.

This hasn’t been addressed yet and is still on the list - 2.45 is a work in progress. Thanks for the extra information, though.