Ebook Compile - inserting random chapter titles not in text

I am having trouble creating a mobi ebook. The compiler is automatically inserting “chapter 1,” etc., into the text, except that the chapter titles it is putting into the text does not match the actual chapter name. Any idea how to deactivate this function? I’ve made several ebooks, but this is the first time the program has ever auto-inserted chapter names into the text. It looks even more odd since I have the correct chapter name already in the text. Any help is greatly appreciated!

The chapter titles inserted by Compile come from the document names in the Binder.

To get rid of them, uncheck the “title” box in the Compile -> Formatting pane.

Katherine