Edit Formats in Compile Locking

Hi friends, I’m facing a problem with my Scrivener running on Wine. I followed the tutorial from this topic: How to Install and Activate Scrivener v using Wine - #26 by Bumblewoolfy

Every time I click on some ready-made format in the ‘Compile’ menu and choose the copy option for editing. Scrivener automatically locks and closes without displaying any messages.
So I am not able to create and edit export formats for my texts.
Has anyone ever experienced this? Or would you have any suggestions to fix?

Or even creating a new format. The Scrivener ends up closing.
From what I understand, the rest of the features are working perfectly.

I have a Windows PC. I was thinking of editing the format on this PC and then exporting and importing it into the Wines version, will it be possible to do it this way? At least this solution could work around until finding a definitive solution.

First demonstrate that you can do what you’re trying to do with your project on a Windows PC. If it works there, but not under Wine, then you know that it’s a Wine related issue and can start trying to figure out what your workarounds/troubleshooting steps should be.

If it doesn’t work there, then there is something funky about your project.

Have you tried this with a brand new project, or by opening a brand new copy of the tutorial project, to confirm that you don’t have an issue with the project you’re trying to work with?

Thanks for the help.

Yes, with Windows it works perfectly.
That’s why I believe the problem is Wine, but I can’t relate the problem to possible causes.
I don’t know what scriver to use when calling this menu. I can’t think what would be missing to be able to try to fix.

But thanks for your attempt to help.

I may have run into this a while back, when using a different version of Wine. If it’s the same thing I was seeing, then you should be getting some debugging output that you can see if you enable the Show internal log console option, in General: Warnings (you’ll need to restart the software after setting that).

If it’s shutting down before you get a chance to see anything, you can also try launching it from the command-line, by navigating to wherever it is installed, and running:

wine Scrivener.exe --log

This will dump everything into the shell. My guess is you’ll see some error messages about missing DLLs. You may be able to install those with winetricks, but like I say I’ve never tried to troubleshoot it because a Wine update sorted it out.

Analyzing my Scrivener installation. For some reason. It is running on an ENV:
(env WINEPREFIX="/home/fil/.wine32" wine-stable C:\windows\command\start.exe /Unix /home/fil/.wine32/dosdevices/c:/ProgramData/Microsoft/Windows/Start\ Menu/Programs/Scrivener\ 3/Scrivener.lnk)

The suggested command did not run Scrivener. It did load some things, but it finished and a message came out: Warning: No voice found for given locale
The log also shows the absence of some sources, but I don’t think that’s the problem.
Thank you very much for trying to help.

That is how you select a Wine prefix. If that is something you need to do, then you have to preface the command you wish to run (above) with setting that environment variable, so that Wine knows where to pull everything from. You only need to do it once per shell session.

Was there ever a solution to this issue? I’m suffering from it at the moment.

It might help to ping them (like I just did here ⇒ @felipefm), so they are more certain to get an email notification. Who knows?

My situation was very different. I got a very clear statement of the missing .dll files in the log output. I just ignored it until the problem was later fixed upstream. I’m running Debian stable, Wine 5.0.3.

1 Like

Hello friends, sorry for not getting back and reporting my progress.
In fact when executing the log command it did not return any missing DLL information. But I believe that the command is not executing correctly.
Due to lack of time, at the time I left this problem aside and got around it using windows. I edited what I needed and then imported it into Linux.
I haven’t had much time to try to solve this problem. But I hope to get it soon. As soon as I have news I’ll let you know.
Thanks again for the help

No worries! Well hopefully somebody figures something out.