Edit>Options not Sticking Around

Just grabbed the program last night, and I’m loving it. That said, I’m having some trouble with a few things.

I. Tab Stops

  1. When I go into Edit>Options and go to the Editor Tab, I set a left tab at .5". Hit OK.
  2. When I add a new Text Document, there is a tab, but it’s at 1.1".
  3. I return to the Editor Tab, and the tab shows at 1.1". I fix it to .5" and choose OK.
  4. I go back into the Editor Tab, and the tab shows again at 1.1".

II. Right Margin
My Edit>Options, Editor Tab, doesn’t let me set a Right Margin beyond 5.1". Not that it actually applies to a new document. New documents are coming in with a RM of 7+".

III. Split At Selection, first paragraph formatting
When I take an imported document and attempt to Split it at # scene breaks, I right click and choose “Split at Selection.” The bit below the hash does successfully go into a new file, but the first paragraph is single spaced, and has a margin of 1.1". That latter bit makes me think that the line spacing option of 2.0 that I picked in the Editor Tab is also not sticking around… and the only reason that my stuff is double spacing is because that is the way it imported, or was copy/pasted, or was broken out. However, when I choose a new document, the line spacing is 2.0 still… so the setting is there, just not applying to the first para.

Copying the style of the second paragraph and pasting that style to the first paragraph does not work… if that should work.

Incidentally, when, in this case, I select everything (CTRL+A) and go to apply a tab stop at .5", the first paragraph immediately “fixes” itself to be double-spaced.

Where would I change line-spacing for an extant file/para like this (rather than going to the Editor Tab for options against a new document)?


I’m having the exact same problem with tabs. It doesn’t matter what I set the tab stop to, it always reverts to 1.1" . I started my project in the earlier Betas, and the tabs set then are exactly as I would have expected. (Though unfortunately I don’t remember if I went through a different procedure to set them.)

I can change the tabs on an individual document basis, using the ruler, but obviously this is a bit of pain to do for each and every document.

Thanks both of you for the reports. I’ve likewise seen that the tabs set in the Options don’t stick, so I’ll be sure Lee is aware of it and it will get fixed.

Taking the other items in order:

Two issues here. First, you’re actually talking about the right indent, not the margin; it may help you to see Ioa’s post and explanation on the margins/right indent here. Either way, the issue with the indent limitation has likewise been noted and will be fixed.

Second, when you say “new documents are coming in” do you mean imported documents? If so, then that’s expected–documents that you import will not have their formatting or ruler settings changed to match your Scrivener defaults. This is intentional, so that you don’t lose your formatting; it’s easy to switch them by just selecting the imported documents in the binder and choosing Documents>Convert Formatting to Default Text Style. That will give you some options on what specifically you want to convert—you will probably want to check the box for “preserve font styling” at minimum, unless you want your italics, underlining, etc. to be overwritten. (In future, this will be adjusted so that it will automatically preserve such formatting and you won’t have to select it yourself.)

If however you meant that you documents you create in Scrivener aren’t conforming to your Option settings, that’s a bug.

I’ve seen some other reports of formatting getting weird at a split, and I’ve gotten some of it myself, but it’s all just been character attributes or font–I haven’t managed to replicate the spacing issue you’re seeing. It’s probably all related and will get fixed together, but if you could provide any more specifics it might help pinpoint this. What type of document are you importing as–rtf? doc? When you split are you selecting the hash mark or just placing your cursor inside the text? I’m assuming from your post that the imported document is double-spaced; does it also have a first line indent? (You mention the “margin of 1.1” which I’m thinking might mean the tab stop or the left indent–what was it for your original document?)

Copy Style doesn’t seem to be bringing over the ruler settings, as you observe. That will get fixed or else the options may be divided into something like Copy Ruler and Copy Font. Either way, it should be possible, although I think it may not be the easiest method here. Instead, you should be able to select all and adjust the spacing via the Format menu or format bar; you could also select the documents in the binder after you’ve finished splitting and use the Convert to Default Formatting to correct the spacing, indent, etc. (and once this is fixed it will insert your tab stops as well).

Thanks for the information, MM. Good to hear about the Tabs. Now, about the other stuff…

Yes, I wasn’t completely clear in what I said. Thank you for the link to that other thread. My issue with the right indent is that it was defaulted at less than what I wanted as a margin, and so was acting as a de facto margin in my editor. Provided that AmberV was talking about correcting this when she talked about having the right intent just become disabled when you drag it all the way to the right side of the ruler, then the problem should be addressed.

Just to be clear, though… she said that if the right indent is dragged all the way to the right it should become disabled. I disagree, unless by “all the way to the right” she is talking about a programmed maximum value to the ruler. Pushing the right indent out to 5.something and having it disabled doesn’t do much. But if the ruler scrolls out to the maximum length (say, 20"), and then the disabling kicks in, then that could work. The important thing is there could be a reason for right indents greater that 5.x.

Probably all things that were considered, and probably all considered to the same conclusion. I just like to be thorough in my feedback.

Next, the Splitting of a document.

Here is what I do to create that problem:
I have an existing document created in Word 2003.
The document has paragraphs indented via TABS, not a first-line left indent. And it is double-spaced.
I save it as RTF.
I import that RTF document into Scrivener.
I go find the # breaks, and put my cursor into the text just before the TAB character of the line following the #.
Then I right-click and choose “Split at Selection.”

The new document created (with the text below the point of the break) has the formatting issue.

(Incidentally, I have tried this same process again tonight, and have not yet produced the problem. If I do manage to replicate it, I will post back more details of the process that made it happen.)

Thanks again!