Editing (external) link type results broken link

Scrivener: 2.4.1 (22817)
OS: 10.7.5

(1) Select some text and add an external link using “Add Link…” (Edit menu)
(2) Drag a file from the Finder into the edit box.
(3) Note: Leave the type set to “Web”
(4) Click “OK” to save the link.

Click on link. It tries to open the “file” link in the browser and fails, which is expected.

Now try to fix the link:
(5) Ctrl-click on the link and select “Edit link…”
(6) Change the link type to “File”
(7) Click "OK’ to save the change.

Click on the link. Nothing happens. This link is now useless an must be deleted/re-created.

Note that if the link type is set to “File” correctly in step (3), then it works as expected - it opens the external file.

Expected behavior: Changing the link type in “Edit link…” should have the same effect as setting the link type initially in “Add link…”

I can’t reproduce this - I just tried it and it worked fine for me. After I switched to “File” in step (6) and re-saved, then clicked on the link, the file opened as expected. Are there any other steps I need to take to reproduce this?

Thanks,
Keith