Editing spaces between words

I’ve written a document in the UK stage play section. Now I want to write it as a novel. I opened a new project and did a copy and paste of the script. The stage play was written in double spacing so I used the formatting to change it to single spacing which was fine. Or so I thought.
I must have done something wrong because there are spaces between some, not all, words and lines are broken.
When I select all, I see blue symbols between words which I assume are formatting.
Is there anyway to edit this document so that I remove the spaces? If not it means I have to edit them one at a time and I could well have passed away before I reach the end of the document!
Any suggestions would be much appreciated.

Three things I would try:

  1. For your trouble document, try selecting the tex and using the Zap Gremlins command (submenu under Edit). See if that helps.

  2. Try the Copy again from scratch. Make a new doc, make sure it is not set to scriptwriting mode. Now, don’t use Paste, use Paste and Match Style. See if that helps.

  3. Start again; don’t use Copy and Paste at all. Just duplicate the script docs and then take each of the duplicates out of scriptwriting mode.


Thanks so much for your suggestions. I tried all of them but without success, unfortunately.


Stay in your original project for the time being, and duplicate one of your scenes as a test.

Then, cmd-8 to change it from ‘scriptwriting’ format to standard format. Then highlight all the text (cmd-a) and apply the default ‘no style’ style (cmd-opt-0). Effectively you’ve turned you script into a normal text document.

Do you still see any problems with the formatting? If not, then all you need to is duplicate your project and go through the same process with all the documents. (Just select every document, press cmd-8, then Documents > Convert > Text to Default Formatting will do the same thing in one go)

If not, please post a screenshot of what you see (with the text selected so we can see the formatting).


Can you post a screenshot? Do you have ‘Show Invisibles’ turned on?

Without being able to see it, I wonder if your “lines are broken” may indicate the presence of a line-feed (:leftwards_arrow_with_hook:︎) at the end for some reason and your text version is justified so the lines are stretched which is done by widening spaces (If invisibles are already turned on, and your “blue symbol” is a dot, that is a space).

If with invisibles turned on, you have some other symbol apart from the blue dot, can you select one (personally I’d use the keyboard rather than the mouse) I’d copy one, paste it in the find dialog with a ‘space’ in the “replace with…” field, and do a single “Replace” to see what happens. If it works, you can then try “Replace All”.

Does that help? :slight_smile:



Thanks for your help. I made a copy and followed your instructions but no luck. So attached is a screenshot.

Maybe this will clarify the situation.

Hi Mark,

Thanks for suggestions. Here’s a screenshot.

I’m not tech savvy so I don’t understand your last paragraph very well other than turning the invisibles on :slight_smile:

To be honest, I don’t see any real issues, other than detailed formatting things I would fix. I don’t see any excess spaces between words which is the problem you report in the Title of your post. Specifically, what words point to the problem?

Note (which you probably know, but I’ll state here anyway for completeness):

: the “right arrows” are tab characters.
: the “backwards P” is a Pilcrow paragraph marker
: you don’t show the “invisible” markers for space between words. Normally with invisibles turned on should be little dots for each space character. I don’t see a setting for that in Scrivener preferences to turn on or off, so maybe a relic of your screen shot colors. A mystery.

Formatting things I would fix, and if I were writing this, I would fix as I go (and while thinking of next words to compose/write):

: extraneous paragraphs at top of the text above “My brother…”
: extraneous tab character after “achievement.”
: inconsistent number of tabs for start of each paragraph, some with two tabs, some with one tab. I never tab paragraph starts and instead rely on the style for the paragraph to add that detail.
: inconsistent use of empty (or not) paragraph breaks, e.g. after “achievement.” there is no extra paragraph marker, but after “scribbled.” you have two. Unless I’m preparing for a LaTex or Markdown compile (which seems to ned it), I never add extra paragraphs just to make space. I use the “paragraph spacing after” for the Paragraph format.

Show/Hide invisibles is in View —> Text Editing —> …, not Preferences (This is not just Scrivener, Nisus Writer Pro, also built on tha Apple TextKit doesn’t have it in Preferences.) I don’t understand why the tabs are shown but not the spaces—perhaps because the OP has the whole lot highlighted in blue; I’m not at my computer so can’t check!—anyway …

The formatting problem is the tabs, which may have been put in after conversion. If you put in a tab at the end of a stretch beyond the last tab set on the ruler (Cmd-R) to show the ruler), it will wrap to the next line and put the tab at the beginning of the new line, which is what you see here.

So, I would use Find and Replace, entering a tab character (Opt-Tab key) in the Find field and a space in the Replace field, do a “Replace All”, then Edit —> Text Tidying —> Replace Multiple Spaces by Single Space to clear out any double spaces.

If the OP wants indents on the first lines of paragraphs, he should set that up in Preferences or Project —> Project Settings



1 Like

Agree with all you say … re showing invisibles, bad writing my part. I was refereeing to specifically showing or not showing the space invisibles vs. all invisibles. Yes, I suspect screen shot colors. Otherwise but the details, I don’t see any major issues. Hence I asked OP to clarify please.

Hello again,

With everyone’s help and suggestions I think I’ve solved the issue. I used project replace and entered option + enter in the find box then in the replace box I entered a single space. This has removed all the paragraph breaks. There are still some double spaces between some words so I entered double space in find and single space in replace but it doesn’t seem to want to do that. But I’ll live with that. Getting rid of the paragraph breaks makes it much easier to work with.
thanks to all,

with due respect, getting rid of paragraph breaks not a good idea as they have a purpose. if you could describe your issues with paragraphs perhaps we can help or re-word our recommendations.

or maybe your writing is without paragraphs? if it works for you, ok then i guess.

Yes, I will need to enter paragraph breaks but I’ll enter those as needed while I’m editing a second draft.
I still can’t remove double spaces between some words although I did try by using project replace and entering a double space in the find box then a single space in the replace box but no changes happened. Any idea what I’m doing/not doing that I should be doing?

Try Edit → Text Tidying → Replace Multiple Spaces with Single Spaces as I suggested above. It’s there in Windows as confirmed on another thread saying what you’re trying doesn’t work.


Yes, I’ve just used Text Tidying and sorted the multiple spaces to single.
Thanks for all your help.