Editor Jumps

Hi everyone. I haven’t found this topic posted before, so I’m not sure if I didn’t know what to search for, or if no one has this issue.

I’ve made sure typewriter scrolling is off in both the standard edit modes and compose mode, and yet still the editor will jump and recenter the editing point around the middle of the page.

For eg, if I am revising a document, and I am looking at the top line in the edit window and delete a word, the editor then pushes everything down so that that line is at the center of the screen. It is so annoying, breaking my workflow and focus, and it takes me a few seconds to find the insertion point again.

Is there any option to turn this feature off?

This isn’t a feature so much as an overly generous use of an underlying behaviour in the text editor. Basically if you put your cursor on a line and then scroll to another area of the text so that the cursor isn’t on the screen and then start typing, this is precisely the behaviour you’ll get: the line you are typing on is scrolled to the middle of the screen so you can see what you’re doing.

The problem is that it is triggering too early and too easily. We hope to have it fixed for a future upgrade, but like I say it’s a bit tricky since it’s technically a glitch in the underlying toolkit.

If you’re running into it with great frequency, consider using the Highlight current line option in the upper-left corner of the Editor preference pane (you can change the colour of it in the Appearance pane, under the Editor section of the customisable colours section).

Thanks, Amber, for the response and suggestions. Glad to know it will get fixed in a future update. I’ve already changed the insertion cursor width (which helps), but I’ll also try changing the current line highlight to see if that helps too.

Happy holidays!