Editor Text Color Settings

I did a quick search, but did not find anything that really answered this. Or maybe I am just a poor searcher. Either way, I have two questions. First off, is there a simpler way to change all my text documents text color other then manually changing each document? Secondly, is there a way to set a default color for the text in the editor. I like to write with a black background and yellow text. Its much easier on my eyes. I normally write this way in the full screen editor, but since I am doing revisions more often, and have need to access my other documents in the research folder, I am using the default editor more often now.

Anything you guys can tell me would be most appreciated!

You can set these colours via the Text Editing pane of Preferences (and background colour via Fonts & Colors preferences). Use Documents > Convert > Formatting… to change the formatting of existing documents using the new preference settings. When you export via Compile Draft, be sure to set the text colour to black, though, or you will end up exporting/printing yellow text too.

Hope that helps.
All the best,

Setting the background to black works, I do not have any trouble with that. I changed my default color of text to yellow, but when I click on convert formating, it either changes my all my text to my default type, but not to yellow color or it just does nothing, and resets my preference text color back to black.

I will fiddle with it some more, but I have already tried all I can think of to get all my documents to yellow type with a black background.

I just tried doing exactly what I suggested and it worked absolutely fine. Just click in the text in the Text Editing pane of the Preferences, hit shift-cmd-C to bring up the colour panel, change the colour to yellow, then click on “OK”. Then use Documents > Convert > Formatting to Default Style, being sure to select all the documents you want to change the font of (and yes, it will convert all formatting, not just colour).

All the best,

I must be cursed or really bad at following directions because It doesn’t work for me. It will change the text type to my default type, but it does nothing to my text color. :frowning:

Oh, and after I click on reformat, I check my text preferences and it just resets it back to black from yellow. Shrugs

I have 1.5, so I do not know.

At the risk of sounding patronising, when you have set the text colour in the pane of the preferences, have you remembered to click the button at the bottom before you click ? I have wasted an irritating amount of time with preferences not actually taking and then realising I haven’t clicked . I’ve just tried setting text colour and it has worked without a hitch.


Yes, I do click apply. I do not understand what is going on. I have followed the instructions to the letter. But no matter how I try, I cannot get my documents to convert its text to yellow, or make yellow my default color for new documents. :frowning:

Tomorrow morning I guess I will delete and reinstall scrivener, maybe something funky happened when I was playing with the beta’s.

If the text is reverting to black then it means that the changes haven’t taken for some reason. Be sure to close the preferences panel after this change, perhaps?

I reinstalled, and now it magically works fine. Shrugs

Thanks for the info though, I have it just the way I want it now! :mrgreen:

Strange. Actually after I posted earlier I noticed all my text was still coming out yellow, even though I had reset it to black. So there is definitely a sticky factor here that I will look into.
All the best,

Yea, I just played with it again and its doing it again. So there must be something funky going on.