El Capitan 10.11.2 crash on loading project to Full Screen

Removing the ui.plist worked for me as well, and I’d frequently crashed on full screen. Thanks y’all, file is attached below.
ui.plist.zip (25 KB)

Thanks! Full Screen has never been the most stable of environments, from the very start it was a mess, and jamming the whole Split View system into it seems to have had a further negative effect on its stability. Hopefully we can find something in these files that suggests otherwise, but given the projects seem to work fine on other machines, there probably nothing at all wrong with them—just that they are requesting a view mode from the system that is inherently unstable.

Same here: after deleting the ui.plist file inside an old project, I can finally open and use it. Not the ideal solution, but in the meanwhile it’s working…

Hi all – Turns out that my Scrivener preferences files were damaged during the upgrade to El Capitan. I had to go into the library and get rid of them, then everything started working just fine again.

Pasted below, find the fix from the Scrivener team:

<<>>

// PLEASE REPLY ABOVE THIS LINE

I’m afraid the crash report was not attached to your email.

Have you tried resetting Scrivener’s Preferences files? If not, please do so:
Please do this, which will reset Scrivener’s Preferences file:

  • Close Scrivener.

  • Open Finder and click the “Go” option in the menu. Hold down the ALT/OPTION key to reveal the “Library” folder, then click it to open it.

– If you are using the Mac App Store version of Scrivener, browse to “~/Library/Containers/com.literatureandlatte.scrivener2/Data/Library/Preferences”

– If you are using the direct-sale version of Scrivener (downloaded from our website), browse to “~/Library/Preferences”

  • Find any files that begin with “com.literatureandlatte.scrivener2” and copy these to your desktop (this is not to be confused with the com.literatureandlatte.scrivener2 folder that you encountered while getting to the Preferences folder).

  • Now delete the original copies of the files that start with com.literatureandlatte.scrivener2.

  • Restart Scrivener.

If your original account crashes, but a new one doesn’t, one possibility is that the Preferences file for your original copy of Scrivener is damaged.

(Just to clarify, the El Capitan crash fix changed your Mac’s global preferences file. Here, I’m just asking you to reset Scrivener’s own preferences.)

Katherine

Thank you. I’ve been crashing all day and this works. I haven’t attached a crash report - got a little tired of sending them after five or so.

Thanks, evanleatherwood for posting that fix. It worked for me.

Just to help anyone else, I can share of few of the things that helped me:

  1. Launching Scrivener while holding the shift key and then opening up a new project. With a project open, I was able to open my old project just fine.
  2. Once the old project was open, I exited full-screen mode. The old project opened and closed fine in regular screen mode.
  3. Evenleatherwood’s directions to reset the preferences allows me to open in full screen mode again (for now!). I lost a few preference settings, but no big deal.

So all is well with me now. Happy Writing! :smiley:

JTell here – this fix worked for me. Once I got the files open (after multiple reopen forces) I took it out of full screen mode, closed, and reopened with no problem.

A simple fix for the time being!

I didn’t find that deleting the scrivener preference file worked for me. In fact it made the problem worse and I repasted the file from the desktop. However krsjnic’s comment about reaccessing the file and then exiting full frame worked on my Intel Mac mini.

Phew!! Thanks. Hope this work round eventually gets sorted!!

There should be no need to reset the application preferences, the piece of information that stores what mode (full screen or standard) a project should load in are saved inside the individual project’s settings file, as describe in my above post.

What AmberV said. Resetting the Scrivener Preferences helped that specific individual – he reposted a suggestion that I sent him through our support system – but it’s not a general solution for all crashes.

Generally speaking, I encourage users to simplify the problem as much as possible. First open Scrivener with no projects, then with one project at a time. The more precisely you can define the circumstances that cause a crash, the easier it is to fix the underlying cause.

Katherine

That’s also my experience. I had a few crashes since I am in the Apple beta program and for a while every update of the OS was producing an initial Scrivener crash (BTW, it’s not just Scrivener). But it’s never been a major issue. I never had to resort to drastic measures like resetting preferences. And especially if you tweaked a lot the default prefs to your liking, it’s something you don’t want to rush doing.

The Scrivener project containing my book manuscript crashes repeatedly at launch. Other projects open fine. After reading this thread, I don’t think the problem is with the file itself but with the fact that I closed Scrivener while in full screen mode in the project. It crashes while attempting to launch into full screen mode (the other projects that open were not in full screen). I tried the fix suggested involving setting aside ui.plist, and it does allow me to open the project, but this wipes out all of my color labels, etc. which contain irreplaceable information about the status of different parts of my draft and research notes. I really don’t want to lose that information. Are there any better fixes or any other information I can share about my experience with this problem that would help?

Oh, and here’s the ui.plist. But like I said, although I can actually open my project after removing this, it wipes out my labels, etc., which is a problem.
ui.plist.zip (5.91 KB)

OK, actually, I found a simple temporary fix. On a whim I tried opening from the .zip I had made of my project as a backup. Zipping and then unzipping the project works! It launches it in a window, not in full screen, but otherwise everything is exactly as I left it last time. This strongly suggests that the problem is indeed with launching in full screen mode, not with a corrupt file.

To test this I created a new blank scrivener project, put it in full screen, and then quit scrivener. Then I tried re-launching the blank project. Scrivener crashed. But when I launch my book project (from the unzipped copy) it opens fine. The problem certainly seems to be full screen.

Sorry to post yet again, but out of habit I accidentally quit while in full screen, yet again, and this time the zipping/unzipping didn’t work on its own to fix the problem. I could open my book manuscript, however, after opening another non-full screen project. But, at this point I don’t know if this is just random or what.

You could try editing the ui.plist file to change

<key>MainWindowIsFullScreen</key> <true/>
to

<key>MainWindowIsFullScreen</key> <false/>

I haven’t been following this issue from the inside and haven’t recreated the crash on my system, so I’m not sure if that’s enough to fix it, but it’s an easy thing to try.

In any case, removing the ui.plist file and starting fresh does not erase your labels, status, etc. It just affects how that metadata is displayed throughout the project. For instance, selecting any item will show its label and status in the inspector, but you will need to re-enable settings like View > Use Label Color In > Binder or View > Corkboard Options > Show Status Stamps to show the label as a colour stripe in the binder or the status written on the index card.

The full screen animation in El Cap is a pain, not only for Scrivener. Fantastical 2 needs to be toggle on and off full screen to show data properly, Messages takes a while (truly a long time!) to get refreshed if left in full screen. Other apps also have issues. Scrivener is the only app that in my experience has project-specific crashes though. I have quite a bit of experience on this because I work with pretty much everything in full screen mode (or split screen, and it’s the same, for some apps). I think for the time being the best across the board solution is to be mindful about it and get out of full screen mode before turning off the computer or closing the project.

I upgraded to El Capitan, then tried a relatively straightforward compile format adjustment. Yesterday, it didn’t work. THis morning, I got the result I expected. I had restarted after the El Capitan update, then tried the format I mentioned above without success. I restarted this AM, and everything seems copacetic. Who knows what evil lurks in the heart of Apple?

I’m not following, do you mean to say you had problems compiling in Full Screen mode, but not outside of it? That doesn’t sound anything like the bug this thread is about though, which is regarding crashing on project load when projects are set to load in full screen. If you’re having issues compiling from Full Screen, then start a new thread for it, as that doesn’t ring any bells for me, and could be a new issue.

I’m having real problems with Scrivener for the first time and I’m assuming it’s El Capitan.

I can’t open some old files as Scrivener crashes when I try. I tried the fix going into Preferences and deleting the relevant files as discussed earlier and that worked. But, half an hour later and it’s reverted back to the same problem. If I try to open a file, say, ten times, it might open once but then the next time I try, it crashes.

Really worried I’m at risk of losing work. The backed up versions on my USB don’t open either.