El Capitan 10.11.2 crash on loading project to Full Screen

Hi guys – major problems here since I upgraded to El Capitan 10.11.2 yesterday. Scrivener keeps crashing on open. I have successfully opened a new file, but none of my existing files will open. Haven’t updated my iMac, it’s on 10.11.1, and all is working fine.

The machine having issues is a Mac Air, and it happened almost immediately after I upgraded to the new OS. I have deleted from the machine and done a clean install, and that didn’t help.

Would love to hear some suggestions… thanks!

The software seems to be running okay with 10.11.2 for me, it must be a problem with the machine or maybe even just your user account. It’s really hard to say without any information though. Do you have crash logs or console error messages from your attempts to load existing projects? Can you think of anything you typically do when setting up a working project, such as adding composition mode backdrops, importing web pages, PDFs, etc?

Hi Amber,

I submitted multiple reports while the problem was ongoing. I’m using my account just fine on the machine that wasn’t upgraded. I wasn’t doing anything new or different, just opening my current project. It wouldn’t open, so I sent the crash logs. There should be a number of them from this afternoon.

I was able to open a brand new project with no issue.

This happened yesterday, and I was able to get my current WIP open after about ten tries. Worked in it, saved it, dropboxed it, then today, nothing. Crashed every time.

The only thing new if the software update.

I’m experiencing the same thing today. You will find attached the crash report from Console. The crash happened when launching Scrivener for the first time after updated to 10.11.2. So, Scrivener tries to open my last project. After some crashes, Scrivener finally opens so I could close the old project and start a new one… Now, when I launch Scrivener, it opens fine and my new project appears.
Scrivener_2015-12-12-093844_MacBook-AirLC.txt (56.7 KB)

I have experienced the same thing a few times when upgrading El Cap to a new release. I am in the beta program and can’t even remember which version of El Cap I am running. Generally it’s only one or two crashes before the issue solves itself. I even started a thread on this. The culprit seems something to do with the address book (judging from the console error messages)

Experienced this a couple of times. Didn’t realise it might have something to do with the Capitan upgrade. After re-booting the machine Scrivener seems to open and close in the normal way.

The same. No crash for new projects.
Scrivener crash 2015-12-13.txt (56.7 KB)

The two crash reports I see refer to what appears to be some low level drawing stuff, probably trying to create the project window. Since new projects open fine, and the software starts working after a reboot or two, it’s probably a transient bug with the OS X updater. If a simple reboot doesn’t work, I’d run some routine maintenance with Onyx or similar.

Regarding address book, I don’t see anything about that in these two crash reports, so that’s probably something different. I’d start with disabling Scrivener’s Contacts access in the privacy system preference pane. A small number of people using 10.11 have reported having this enabled slows down Scrivener to an unusable state. So we already know that system component can be unstable, might as well eliminate it from the equation and see if that resolves things.

I have not logged in since upgrading to El Cap and now my Scrivener crashes on every attempt to open.

Crash Report attached.
ScrivenerCrashReport.pdf (108 KB)

Update. Scrivener 2.7 with OS X 10.11.1 and the same project (100 MB) works correctly in my Macbook unibody late 2008 (8 GB RAM). Also it works fine in 10.11.2 for NEW projects on my Mac mini late 2012 (8GB RAM). Only NEW projects. IMHO, this is an incompatibility of Scrivener 2.7 with the latest OSX update, but it affects only old projects. :confused:

Scrivener’s Contacts access is always disabled in my computer. I have also executed Onyx before my report: repair permission, scripts and cache.

I am unable to open a new project, because it keeps trying to load the current project I want to work on and crashes. Is there not a work around or fix?

One approach that seems to work for me is as follows:

When Scrivener crashes, click “Reopen” and hopefully it will do so.

In Preferences, under the General Tab, un-check “Reopen projects that were open on quit”.

Then close and reopen Scrivener and with luck, you should be able to select your existing project from the recently open list.

I hope that works for you.

Ray

You can start Scrivener without any projects by holding the Shift key while launching the program. That’s the “official” way to avoid getting “stuck” when Scrivener wants to auto-launch a problem project.

Note that if only one project crashes but others are fine, there is probably some kind of corruption in that specific project.

Katherine

Hi all. I’ve encountered exactly the same problem as jtell. All my files crash Scrivener when I try to open them, and the only thing that’s changed is my upgrade to El Capitan. This is happening for files I’ve made since the upgrade and files I’ve made before. Scrivener tells me they are open on another machine (which I know is impossible as my other machine has been off for 72 hours), prompts me to make a copy, and the crash cycle begins.

Has anybody found a solution to this problem?

For me it’s strange:

I’ve had a lot of crashes, but funnily, when I close a project… For instance: I have 2 projects open, I close one, it’s busy making it’s backup, and then it gives a message it crashed (taking the other one with it).

It’s not been super annoying for me because:

  • the autosave makes sure I never lose anything.
  • I do have the feeling it first finished the backup and then crashes.
  • unlike some other people here it never fails opening a project, and it never crashes during working, so I thought it was a simple bug somewhere that could get solved in a .1 update.
    I sent some crash logs, but not all.

I have it both on my iMac and my Macbook Air. I have the latest El Capitan, latest version of Scrivener from the App Store. No old projects, I just started using the software lately for the first time.

Important: If you are experiencing a crash that does not match the OP’s description, please search for an existing thread that matches your crash, or make a new one, thanks!

We’re still looking into the problem that involves crashing when loading existing projects on some systems. One common thing found in the crash reports is an OS X animation sequence that may be involved with transitioning the window to Full Screen mode. Is anyone experiencing this bug not using Full Screen mode on the affected projects?

There is a way to clear the project’s display settings while it is closed. Something you could try is duplicate or zip one of the projects in Finder to create a quick backup, then right-click on it and select “Show Package Contents”. Drill down into the Settings subfolder and set aside the ui.plist file. Now try double-clicking on the project to load it.

If that works, we’d appreciate a sample of your ui.plist file so we can try and reproduce it on our machines. PM it to me as an attachment or mail it in to our tech-support, referencing this thread URL in your e-mail.

That’s an older bug from 10.10.

This seems to work for me.
ui.plist.zip (8.96 KB)

Excellent, hopefully that works for everyone else. Thanks for the file, we’ll take a look at that.

You may be onto something here. I don’t think it’s just Scrivener. I have seen other apps having suspicious crashes on my machines and I tend to use pretty much everything in full screen