Elements are Changed to General Text when Copied/Pasted

Running into some issues with elements.

I finished writing my first draft of a play in Scrivener last week and decided today to start working on the second draft. I wanted to move a large section at the end of scene 2 to earlier in the scene, but when I copy and pasted it, all element formatting was stripped out and everything read as “General Text.” The margins were still kind of there, but Character, Dialogue, Scene Action, etc. were all gone. I undid that and instead tried highlighting the section I wanted to move and manually dragging it to earlier in the scene. Again, once it was in the right place, everything that was moved read as “General Text.”

Is this expected behavior from Scrivener? It’s astoundingly frustrating that I can’t move around text in my script without losing element formatting, as fixing everything manually would take a ton of time. Is there a problem with installation or build-in behavior, or am I just missing something?


What version of Scrivener, and on what platform?

While we sort out what’s going on with copy/paste, you might try using the Document → Split/Merge features instead.

Thanks for your prompt reply! It’s Scrivener 3 for Windows.

The problem with Split and Merge is that it would require me to split the document at three different points of the scene and then merge them in a completely different order. That gets very complicated very quickly. Plus, I don’t want to need to split and merge every time I move any text in the script, even if it’s just switching the order of two pieces of dialogue.

Personally, I prefer Split/Merge because it makes it easier to avoid misaligned copy/paste errors.

In this case, though, I’m just suggesting it as a troubleshooting step and a workaround while we figure out what’s going on.

What specific script format are you using?

I’m going to move this to the Windows-specific forum to make sure our other Windows users see it.

I appreciate that, thank you!

I’m using Stage Play (US) as the script format. As an experiment, I opened a new document with the Screenplay format, wrote some test dialogue with a Character, Parenthetical, and Dialogue, and then copied and pasted it. It worked exactly as I would have expected, maintaining the elements in the newly pasted version. I then opened a brand-new document with the Stage Play (US) format and tried to do the same without success. So it seems to be a specific issue with the Stage Play (US) format.

Just for clarity, here is what I am trying to do:

If I were to copy and paste or highlight and move this piece of dialogue…

TOMMY [Character]

(Looks around) [Stage Direction]

This is what I am saying. [Dialogue]

…it would automatically show up as this:

TOMMY [General Text]

(Looks around) [General Text]

This is what I am saying. [General Text]

It appears like this issue might just be with the Stage Play (US) format in Scrivener 3 for Windows. I tried copying and pasting in document the iPad version and it preserved the formatting just fine.