Eliminate Auto Spacing After Quotations and Other Punctuation

I have been using Scrivener for some time and suddenly when I use quotations and apostrophes, the program automatically inserts a couple of spaces afterward and I cannot figure out how to turn it off.

What setting is causing this and how do I stop it? What purpose does this serve? I cannot think of any situation where this would be necessary.

I can’t imagine either why this would happen. I assume you have smart quotes turned on? (Tools > Options > Corrections, then look under Substitutions.) You could try turning them off, click Apply, then turn them back on to see whether that fixes it. If not, I’d try closing the program altogether and restarting it. Programs sometimes get some junk stuck in their memory, and restart sort of “burps” them. Apologies if you’ve already tried these.