Em-dash and ellipsis substitution doesn't work in screenplay mode

When I have the boxes checked in options to replace double hyphens and triple dots with em-dashes and ellipses it works in other formats, but not in screenwriting mode.

Windows 10

Not a Windows user, but in the manual for Scrivener for Windows, it indicates there is an option to “Disable smart quote, em-dash and ellipsis substitution in script mode”. Is that active on your PC?

Scrivener_Manual-Win OPTIONS.pdf (149 KB)

Yes, that was it! Thank you.

A pleasure to help.