Em Dashes and Compile (WindowsVer3)

Scrivener version 3 for Windows.

Double hyphen converts automatically to em-dash when typing. As expected.
When compiling it converts them back to double hyphen. Not as expected.

I looked at the manual and it said, ‘most formats will convert em-dashes to double hyphens’.

Okay so what formats do not do this? What setting (and more importantly WHERE) is it to turn off em-dashes converting to double hyphens during compile? It’s not where the smart quotes are. In previous version it was an actual flag along with the italic converted to underline.

Needing to make formats for Shunn Modern and that allows/requires italics and em-dashes.

Thank you,
-Sterling