Embarrassed that I can't get "Preserve Formatting" to work!

Hello, all –

I’ve spent the last hour browsing the forums, and after talking with a fellow Scrivener 2.0 user yesterday who is also struggling with this, am deciding I need help.

For the life of me, I cannot get formatting preset called, say, “Email” or “Newspaper” to work as expected. It will show up on the screen in Courier, with the banded box around it. But, whenever I compile the document into a RTF or DOC file, it always reverts back to the standard font and indentation.

Can someone help me figure this out? I’m attaching a screenshot of the editing window, the Compile Formatting settings, as well as what it looks like in TextEdit.

A checklist or cookbook of how to do this would be terrific.

I would be deeply grateful for any help!

PS: I learned that my friend has resorted to spending hours manually reformatting the document each time he generates a draft. Holy cow. I don’t want to do that! :slight_smile:


formatting options 2011-05-18_10-24-51.jpg
formatting in textedit 2011-05-18_10-27-12.jpg

Hmm, I’m a bit thrown by this one. Could you please zip up the project and send it to kb-tech-support AT literatureandlatte DOT com so I can take a look?
All the best,

Keith –

Many thanks for your offer. Astonishingly, I stumbled upon the solution while trying to comply with your request.

I duplicated the document in Finder, opened it to delete all the folders outside the Manuscript to reduce the ZIP file size, and then did a Compile.

Much to my astonishment, the RTF file had the correct preserved font/typeface and margins.

So, for anyone else having this problem, I posit this as a potential solution/workaround:

  • close the Scrivener file
  • duplicate it
  • open the new Scrivener file
  • allow it to reindex, etc…
  • Compile

Many thanks for your help! You rock!