Empty Scenes

I opened a file I hadn’t opened in a while

. When I opened it I noticed a scene that had no data on it (that definitely should have!)

. I clicked on it and, sure enough, it was empty. I then clicked on another scene that, in the binder, showed data in it… and it, too, came up empty (the line at the bottom said ‘zero words’).
I immediately saved as ‘corrupted copy’ and did some more testing. When I clicked on the folder for those scenes I saw a whole bunch of note cards with text on them, but each time I tried to open one I got an empty scene.
I should theoretically have backups, and I have compiles so I can put the data back in, but I am paranoid about opening anything else while Scrivener is in this state!

Typically, this sort of thing happens for 2 reasons. First, you’re storing your project in a folder that is using iCloud /Desktop & Documents sync. Mac OS conveniently removes local files that haven’t been accessessed recently, assuming you’re going to browse for them in the Finder; Scrivener doesn’t access its files that way, and so you end up with a bunch of blank files.

The second way is if you copy the .scrivx file from a backup or a web browser interface of a sync service like Dropbox.com or Google Drive. I don’t think that’s what’s going on, based on your notecards showing text, since the files the synopses are stored in would also be missing if you just had the .scrivx file (a list of binder titles, keywords, and other “metatdata”.

Definitely locate your backups now, before you open and close your project too many more times. Copy those backups somewhere else, and then pick the most recent backup file, open it, and check for good data. Work your way back until you’ve found a good copy. Alternately, use something like Time Machine if you had that set up, and restore the main copy from there.

Good luck in recovering your data, and I hope you figure out what happened so you can avoid the issue in the future.

The note cards display each document’s synopsis. The Editor displays the document’s text. If you did all your writing in the note cards, you have a synopsis but no text.

If that’s the issue, open an “empty” document and look in the Inspector until you find the synopsis, then copy it to the empty Editor pane.

The notecards display a synopsis… if you put one in. If you don’t it displays the first few sentences of what you did put in. Which is helpful, but which should indicate that there is something in the underlying scene… which I know there is, or should be, because not only do I know the work, I have a compiled copy!

Yeah, I’m not as panicked about recovering the data as I am about Scrivener becoming unworkable because of this problem. For obvious reasons I store everything on the cloud, but I won’t be able to if this bug keeps coming up.
Does anyone know a way of not having this happen? Someway of opening it that doesn’t produce this effect?

The irony here is that on the Mac it looks as of there was only one file. Where is this data that it has to load that it can’t find?

Like applications, the Mac has a way of packaging a folder’s contents to look like a single file. But Scrivener project are in fact a folder with many files & subfolders, to allow external apps’ files to be imported into it and opened directly by them.

Some cloud services make room on your computer by deleting the data of a file that has been synced up to their servers, leaving a vestigial object on the filesystem. When you interact with that file the “normal” way, via the finder, that triggers the service to re-download that file’s data before handing it over to the default application.

So, this isn’t a Scrivener problem per-se. Most other apps zip up their files every time you save/quit the app, and otherwise keep everything in RAM, making them risk losing all changes to a power outage. The way to prevent this is to use a sync service that doesn’t clear away files for you, but always keeps a full copy of your files on your local hard drive. Dropbox does this. Some other services do too. I believe if you can turn off the “optimize storage” option in icloud, you can prevent it from deleting files, but probably won’t restore these deletions. Signing out of iCloud may trigger a prompt to download copies of everything to your hard drive.

It’s not happening to anyone else, so far as I know.

We could probably fix it in a Zoom session, if you want.

DrMajorBob at Facebook

This is not a “bug,” at least not in Scrivener.

This is your cloud storage service behaving exactly as designed – most likely by helpfully “optimizing” material so that it is stored only in the cloud. The solution is to tell the service not to do that.

Scrivener writes to and reads from the local hard disk. If other software then moves the data to another location, there’s not much that Scrivener can do about it.

That’s one explanation, maybe the right one, but how likely is it that a cloud service would keep all the synopses on disk but not the text documents? Is it because the user had been looking only at corkboard view for quite a while?

We could probably fix it in a Zoom session, if you want.

I don’t have Zoom, and I have a lousy connection, but I’d love to get together to fix it if we can arrange it.

I almost never use cork board, and I don’t believe that these were synopses. I think they were the automatic synopsis that you get from the beginning of text.

I think the automatic synopsis isn’t saved anywhere unless you ask Scrivener to generate synopses from the text. Did you?

As I said, this is a very old project, that I haven’t opened or worked on in a year or two or maybe even more. So I can’t tell what I did.
However as to the ‘not a bug’ thing… I think maybe some people missed part of the issue. Let me reiterate:
Scrivner, in the binder, says that there is text in the scene… which it indicates by the type of icon it shows… at least that is my understanding of what it is doing. But then it shows a word count of zero.
And I don’t understand how it is not a bug when Scrivener says, “Hey, I know there is a scene here, but I can’t download the file for it” that it goes ahead and says it is a scene with a zero word count (and I assumes saves a new version like that!!!) instead of throwing some sort of ‘file not found’ error.

That’s understandably irritating. But from Scrivener’s perspective, the file is found. It just has no words in it anymore (or: not yet). Because those words are now sitting on a cloud, dangling their little feet.

That could happen if @kewms has the right explanation, since the icon info is saved in the .scrivx (probably, or so I’d think), but the text is saved in RTFs. If she’s right (and even if she’s not), make sure the cloud service isn’t keeping files off the hard drive.

Ok, color me confused. How is the file found if the file is, umm, not found? If I try to load a file from the cloud that is not (yet) down on my machine, I get a little spinning icon. How does Scrivener get a file???

Well, that would explain it if they all behaved that way. But one of them didn’t.

It assumes the file is accessible (stored on a local drive) and that’s exactly what the operating system pretends to be the case. But it’s not (yet). It’s just the illusion of the file. Accessible, but empty at this point. And that’s what Scrivener loads. A fistful of nothing.

Some hours ago I got some small font files stuck on iCloud drive. Double-clicked on them to install, nothing happened. No download, no spinning beach ball, no error message. Forcing the download did exactly nothing. Trying the usual magic to motivate iCloud, nothing. Logging in / out of iCloud, nothing. Had to reboot the machine. And that’s macOS, will full knowledge how all of this works (or is supposed to work).

1 Like

That’s iCloud Drive for you. I don’t use it. Nor do I allow “smart sync” in Dropbox, certainly not for Scrivener files.

1 Like