en dash instead of em dash by default

How do I get double-hyphen to create an en-dash instead of em-dash?
I’ve tried this solution but this doesnt work for me: https://forum.literatureandlatte.com/t/german-quotes/12300/6

When I try to cope en-dash on character map (0x2D) to the ‘replace with’ box, it gets copied as an hyphen. If I copy this straight to the document, it correctly copy as en-dash.

If you click replace after you have copied the en-dash into the 'replace with’ box, what happens in the editor text? I ask this because not all fonts have a specific, easily distinguishable en-dash and em-dash glyphs — in fact, on the Mac, the font this forum uses displays what looks like an en-dash when I input an em-dash — so it the 'replace box’ should have the appropriate 0x2D, but the glyph displayed in the box is indistinguishable, whereas the font you are using in the editor makes a clear visual distinction.


Mr X

There is no ‘replace’ to click, the ellipse on the replace box produce the character map window, from there I opt for 0x27, then click ‘copy’, then I ‘Ctrl V’ to paste in the ‘with’ box, what comes up is an hyphen. On the editor, if I enter an hyphen twice and space it also produces an hyphen, not en-dash.

But if copy and Ctrl V from character map to editor, it correctly produces en dash.

I hope I’m making sense.

Yes, you are, though perhaps I wasn’t. As I said, it wouldn’t surprise me at all if the glyph in the ‘replace box’ looked like a hyphen because of the font used in such controls — and I’m on a Mac, not Windows, so I can’t be definite about it. But when you have entered that apparent hyphen into the “replace box”, what happens if you then click the “Find" button in the Find and Replace dialog, and then click "Replace and Find” or “Replace All”. Do you get en-dashes in your document?

As for typing two hyphens to get an en-dash, I can’t say what’s happening there. That’s a system-wide replacement on the Mac — except it gives an em-dash, not an en-dash — so someone with a knowledge of Windows is going to have to come in to help sort you out.

Mr X

Find and Replace produces a hyphen

The system font used in the substitutions fields will make a pretty short en-dash, although it is distinguishable from a hyphen if you type the two next to each other. Double-check you’ve copied the U+2013 en-dash character from the character map to the replacement field. Then make sure in the Correction options that you’ve selected “Enable additional substitutions” and disabled the option transform a double-hyphen into an em-dash. That ought to do it for you, then, in the editor, but again make sure that in the editor you’re using a font that will show the difference–try Times New Roman, for instance.

Ahh… so Times New Roman does the trick. I was trying ‘symbols.’ Thank you!