Endnotes not compiling right

I really do not understand how to make the inspector footnotes show up as endnotes. I am using the preset MLA formatting and I need my footnotes to show up under the last page entitled “Notes” which comes before the Works Cited page. I finally got the footnotes to show up at the end of the document rather than at the end of each page, but they are showing up at the bottom of the Works cited page, which is totally not OK. And the MLA preset page called Notes, which should be where my endnotes start, is blank. It does seem to think it knows something, because for some weird reason it has gained a wee number “6” as if it is notated too, and “6” is the last footnote number.

So what should I do?

Firstly, if you’re trying to compile to most formats you won’t find the kind of layout you are describing works—the necessary options are not available. When using Print or PDF however, we have a little more control over the matter and provide some options in the Footnotes & Comments pane under the Group notes section. One of those options may work for you, but the MLA template that we provide (not sure if you started with that) is set up to work with the “Before last page break” option. If “Works Cited” is not actually the last page break in the work, you might be better off with the endnote marker method.