Enter/Return change of behavior in most recent update

Scrivener 1.2.2
iPad 12.9 Pro (2nd gen)
iPad OS 14.8
Brydge 12.9 Pro Bluetooth Keyboard (‘Enter’ on keyboard)

Hello… I recently switched back to using my iPad w/ bluetooth keyboard for some work in Scrivener iOS.

It appears that with 1.2.2 being released there was a change of behavior relating to Enter and Return.

My keyboard lists ‘Enter’ and only ‘Enter’ on one key of they keyboard.

Tapping the ‘Enter’ key within an editable document does nothing. Cursor doesn’t move.
Using ‘Shift+Enter’ and I get the previous behavior of carriage return and line feed.
Using the iPadOS screen keyboard I can click on ‘Return’ and it adds a carriage return and line feed.

Looking through Scrivener app settings, Scrivener project settings, iOS settings, and even Brydge’s 4-page manual for an option to change behavior of the ‘Enter’ key and I didn’t see anything.

Is there something I am missing to get the desired behavior of Enter & Return being handled the same way again. Or, a means that I can have Scrivener or iOS swap Enter for Return?

Thank you for your time and consideration!

I am not seeing anything like that with the Apple “flap” thing keyboard that sticks to the side rather than using a Bluetooth antenna. I would have thought the distinction between “Enter” and “Return” would be cosmetic (for that particular key, this has been a difference between Apple and PC hardware since the '80s). It should be.

  • Try in contexts other than the main text editor or inspector Notes editor. These two are rich text editors, which are very unusual on iOS. The Synopsis area of the inspector would be a good test, as that would be using a much simpler editing tool—and the one that is the basis for most text editors on iOS outside of completely bespoke stuff like Pages and Word. Another test would be to hit ⌘N to create a new binder item, and then Enter to submit the dialogue.
  • Since it is Bluetooth, can you pair it with a PC or Mac, where you can use more technical tools to see what this key is really doing? Anything that can show you key codes will do, like Karabiner-EventViewer on the Mac. What you would want to see from this key is 0x28, or the “return_or_enter” key. What you wouldn’t want to see is 0x58, the “keypad_enter” key.

At any rate, this is all well beneath any code Scrivener concerns itself with, as you might suspect. We are not reinventing how keyboards and complex rich text editors work, but using the iOS programming frameworks to handle the decades of work that would go into such things. If an update to the software using new frameworks broke this key, Scrivener is mainly the messenger. But with a little forensic results, we might be able to force the system to see this key otherwise.

Thanks for your response!

I took a quick look at the “Apple ‘flap’ thing” keyboards and see that those are listed as ‘Return’ on the key for whatever that is worth…

Back to my ‘Enter’ biased BT keyboard:

Your first bullet:
Test#1 - Project creation; ‘Enter’ works as expected

New Project - only on iPad
Name: ScrivTest ‘Enter’
Result - Created new project - starts off in blank ‘Untitled Document’

Test #2 - Typing inside of a new document; ‘Enter’ doesn’t do anything by itself

Tap inside Untitled Document to bring focus to it and type in The quick brown fox… ‘Enter’
Result - no carriage return or line feed
‘Shift-Enter’
Result - adds in carriage return and line feed and moves cursor to next line.

Test #3 - Typing inside of the inspector; ‘Enter’ works as expected (carriage return & new line)

Tap in the title field, ‘Test’, ‘Enter’ pressed
Moves cursor to synopsis field
‘Field test’, ‘Enter’ pressed
Moves cursor with a carriage return and line feed with the cursor sitting left of and below the ‘F’ in field and synopsis box dynamically expands down

Second bullet:
First attempt at looking at the keycodes:
Raspberry Pi via SSH using Terminus app and CLI command:
‘showkey --ascii’ replies: ‘13 0015 0x0d’ for both ‘Enter’ and ‘Shift-Enter’
(Possible in the above that Terminus is converting keycodes and I can’t get low enough in the stack…)

No access to a Mac w/o borrowing it from my spouse at the moment.

But, I did go ahead and update the iPad OS to 15.5 just to try that…

…and… of course that worked!

Thanks again for your help!

1 Like

But, I did go ahead and update the iPad OS to 15.5 just to try that…
…and… of course that worked!

Beautiful! Maybe that’s why my Apple keyboard was working as well, as I was testing from 15.5. We’ll recommend anyone else running into this try the update as well.

I had the very same problem - iPad 8th Gen with iOS 14.4, Logitech BT keyboard
When I hit ENTER/RETURN, nothing happened. In other applications (i.e. Pages) the keyboard worked fine.
After an update to iOS 15.7, the bug was fixed.
Thank you!

That’s good to hear, and it really does make sense since Scrivener shouldn’t be messing with anything so low level as how a return key works.

1 Like