ePub export - can't change line spacing in readers

POST EDITED: I have figured some things out, but not all.

I figure this has been covered, but after a lot of searching, reading, and video watching, I can’t figure this out. I’ve looked through the manual and searched the forums. Apologies if this is a repost.

I’ve got exporting ePubs pretty well under control, except for one thing: line spacing

I’ve noticed that ebooks published independently on BN and Amazon often have the same problem, while publishing house titles rarely do. I want my readers to be able to make adjustments to how their text is displayed.

EDIT: I have overridden the text options in the export dialog and then set the min/max line height with a very broad range. This has not made a difference. My lines are scrunched together and are not adjustable.

Font and margins are now adjustable for me in my Nook Simple Touch, which is my primary concern at the moment. Line spacing looks horrible though.


Could you please explain further what you are trying to do, and where you are opening these files? It sounds as though you want line spacing to be adjustable by readers, but I’m not aware of any devices or software that allows this - I’ve never seen such an option on the Kindle, in Kindle Previewer, in Digital Editions or in iBooks; I’ve only ever seen adjustable font sizes. (Being in the UK, I don’t have access to a BN Nook.)

All the best,

Hi, and thanks for replying. Yes, I want people to be able to adjust line spacing. I am specifically concerned with the BN Nook series. I didn’t know that Kindle did not allow this. It’s not just that I can’t adjust the spacing in my ePubs, but that the text is very, very close together. But randomly–without any ordinals or special characters–one line will be spaced out more widely than the others in the middle of a paragraph. It seems that the line spacing adjustment only works on certain lines. I’m totally confused about why this would happen. I really like the ePub format, including a cover image, its wide acceptance, etc., but I have tried others just to be certain. ePub does not appear to be the problem.

And the location of the adjustments I’ve mentioned (minimum line height, maximum line height) are in the ePub Compile dialog under Formatting. Check the “Override text and notes formatting” box, if it is unchecked, then drop-down the line spacing menu and select “spacing.” Here there are minimum and maximum line height options, and I can’t figure out if these have anything to do with user-definable settings in readers.

Regardless, I want to be able to set some “allow users to adjust line spacing” option, for those readers that have the feature.

I am using the latest version of Scrivener.


BTW, I edited that last post because of a mix-up between check/unchecked and because I added a detail about how line spacing options work on certain lines.

I misread your question: where are you opening these files?

On my Nook Simple Touch and original Nook.


You generally don’t want to set minimum and maximum line heights. What happens if you set the line spacing to 1, with no other line spacing settings? This should be the default, and equate to no line spacing settings. I’m wondering if setting any line spacing settings at all causes the custom line spacing options not to work.

Unfortunately the Nook isn’t available in the UK (we don’t have Barnes and Noble over here), so I have no way of testing any epubs on a Nook (and I can’t even sign up for the preview on pubit.com because I don’t have a US bank account). No other e-book readers to my knowledge allow line spacing adjustment - there’s nothing like this on the Kindle or Sony Reader, or in any software epub readers to my knowledge, so this must be unique to the Nook.

All the best,

OK, thank you. Just so you’re aware, I didn’t change the line spacing until I noticed the problem. Even with the default settings, my exports will also generate an extra line between a paragraph when there isn’t one in the text. Or, I should say, Nook interprets something there as a line space.


Double space the text.
Line height multiple: 2.0
Inter-line spacing: 1.0.

It might just be that you have to double space the text. I’m not sure if I was single-spacing it before or what, but Nook likes double-spaced text.


Thanks for your time. I hope I haven’t wasted it.

Weird! Thanks for posting the solution - and no, of course you haven’t wasted my time, quite the opposite; this is really useful to know. So, just to clarify - in order for line spacing to be adjustable on the Nook, it must be set to a line height multiple of 2.0 and inter-line spacing of 1.0, and nothing else, is that correct? This would be useful for our FAQ or Help manual.


All the best,

Those settings are correct. And as far as I know, yes, that’s all you need to do. That is working for me now, no problem. But I can’t say for sure that there weren’t any other factors at work. I exported and had the problem, then changed the above mentioned settings, and then exported without the problem. But there could have been a conflict with something in my custom export template. I wish I had documented my tests with various templates as I was trying to figure this out.

Maybe the tip should be included as a troubleshooting step for people who have modified or created a template and are running into the problem. Your fiction novel template is working just fine for me, and I can’t even remember if I tested that one before. I wish I could provide you with more information here.

Thanks a bunch for your help, and I can’t thank you enough for your software. I love Scrivener! :smiley: