Epub ToC

What code will cause Scrivener to generate the names given the chapters in the Binder and not Chapter One, Two, Three, etc. when compiling an epub?

Earlier I suggested the following:

It depends on what you mean by defaults, but for how the Ebook compile format is set up, the ToC entry is taken directly from how you choose to present the chapter heading itself, via the Section Layout assigned to them. It sounds like you have the “Chapter Heading” or “Chapter” layout assigned, whereas you’d rather have “Chapter Title” or “Chapter with Title”.

To this you responded you don’t have any of these options, but I can see them right in your list of section layouts here. Why not just assign your section type to use the layout that works better for you?

If you’re asking for the sake of curiosity though, see how the “Chapter with Title” layout uses the Title checkbox while “Chapter” does not? That’s the big difference.

Which assignment will yield, for the Epub ToC, the chapter headings shown in the Binder?

Chapter heading?
Chapter?
Chapter Title?
Chapter with Title?
Something else?

How do I restore the defaults?

Where is the title checkbox?

On the 12th try, this worked:

I have the same issue. TOC compile spits out “Chapter 1, Chapter 2” etc. instead of the Names of the chapters. I have read Ch.22 of the User Guide and all the posts I could find on the subject. Nothing helps. Can you?

When you Compile the manuscript, do the chapters themselves have names or numbers? Or both?

Both, in the compiled ePub and PDF. What appears on the screen in Scrivener on ‘paste special’ TOC are only names, not numbers. It doesn’t matter if I compile for paperback or e-book. The compiled TOC never shows the chapter names only numbers.

The main issue though is that the default settings are such that the actual section name (whether we call it a chapter, part, subsection or fig leaf) is used in the ToC (understandably). If you have things set up to print a heading with “Chapter 1” after a section or page break, then that is what the ToC will print. It is what most people would want to see, of course.

  • If you want it to print something else in both places, not just the ToC, then use a different Section Layout for these headings.
  • If you want something less orthodox, where the chapter itself prints “Chapter 1” above the text, but the ToC prints “Fig Leaf One: Name of Folder”, then you’ll have to not rely upon default settings, which overwrite links, or update them to match what you pick for the Section Layout. Again, it’s what most people would want, if a cross-reference to “Fig Leaf” is not meant ot be something the reader sees, and that section prints “Chapter 24”, then you wouldn’t want “Fig Leaf” printed anywhere in the text. But you can turn that off, or change how it works, as described in the link.

My last compiled version printed,
“Chapter 1 Orientation
Chapter 2 Beginnings
Chapter 3 Middle
Chapter 4 End”

Not sure if I should retain the text “Chapter XX” nor do I know how to get rid of them.

I’m confused, your conclusion in this very thread, posted here, shows that you applied the section layout you wanted (without the chapter numbering).

I’m confused too and this thread is two years old.
I wasn’t near a laptop so I couldn’t respond yesterday.
Today I looked at the ToC of my latest project and the “Chapter One, Two Three” is there along with the correct chapter titles. I’m not sure if I should keep them, but I don’t know if I should get rid of them. I followed your link and found the below advice, but where is this setting?

Where is the:

“also disable the Update titles in document links with prefix and suffix settings option”?

I can’t answer whether you should have numbering or not, that’s a personal choice.

Document link conversion is handled by the settings in the Document Title Links compile format pane.

  1. You’re right!
  2. I can’t find the Document Title Links in the Compile Format pane and can’t figure out how to get there.


Sorry, I figured you already know how to edit compile Formats. Well if you need a refresher on what a Format is, and more detailed instructions on how to edit them, this post discusses that pane in particular.

Thanks. It’s hard to reach Compile formats when you’re not compiling.

Thanks again. There’s a lot of information to keep in mind, and as I’m not compiling every day, some of it gets rusty.

This is what my page looks like (default ebook). I don’t see the “Chapter” prefixes there at all and the screen looks very different. This is Scrivener 3.2.3 for MacOs.

Yeah, I’m not sure what you’re looking for in that case. You were asking where the Update titles in document links with prefix and suffix settings setting is, and as you can see, that’s where it is. :slight_smile:

I finally found this screen. This is the default epub format. So the absence of the word “Chapter” in either the Title prefix or Title suffix means that the word won’t print in the ToC?

That’s one way to go about it. A less complicated way would be to assign a Section Layout that doesn’t add that text to begin with, which is what you had done two years ago in your screenshot I think (or maybe you did actually modify it to remove the title prefix from one of the “Chapter X” layouts—can’t really tell from the end result).