epub3 with picture: mysterious failure

I compiled a book wiht 1 picture to epub3 and found that it didn’t pass epub validation because of this picture.

thinking, there might be anew bug in RC 14, I went back to the English version of this book, which I compiled successfully many months ago, and compiled it again. It turned out completely fine!

But in the failed Italian version I had the exactly same piture and the exactly same place (in the research folder).
So I deleted this picture file und inserted it anew from my computer and compiled again.
It failed as before.

Next I deleted the picutre file (taken form the computer) again und pasted in its palce the picute file form the English book project. And compiled the Italien book. It failed again.

I’m at a complete loss now, why it doesn_t work.

I looked (via calbire) in the ebook file and found that in the English book the picture file during the compile process was renamed to something of a long number. In the Italien file it maintained its name, only jpg was named png. And the validator said it could not be found.

In both ebooks, the pictures were present where they shold be.

I have no idea, how to fix this.

[attachment=2]Screenshot_2021-01-13 EPUB Validator (beta) Results.png[/attachment][attachment=0]Screenshot 2021-01-14 070219piratess.png[/attachment][attachment=1]Screenshot 2021-01-14 070711Corsara.png[/attachment]

Could you please, try to disable the compile option “Downsize and resample images to visible size” and try again.

I tried it.This now worked for the validator.

But it’s strange nonetheless. Because with the English edition I got a valid epub out of RC 14 with shrinked picture.

Very mysterious.
At least now I know how to fix it.

This is caused by a bug for the “Max size in pts” being 0. If you specify a non zero value, it should also work. This has been fixed and will be available in the next update.