Error compiling the Scrivomatic sample project

To get started with Scrivomatic I tried compiling the sample workflow project referred to by the Scrivmatic author (@nontroppo) in the Simple Summary of Scrivomatic’s instructions (contained in the readme file on Github). Upon compiling, however, I got an error saying that pandocomatic couldn’t be run, i.e. Tool doesn't exist!!!

Because I am using an M1 Macbook Air it is probably the same issue that @laleleona recently posted about (Scrivomatic issues), related to, as I understand it, the new location Homebrew installs pandoc and pandocomatic to on Apple-silicon Macs. On the other hand, I am not sure my issue is the same as that previous post by @laleleona, so I started this new thread. And even if it is the same problem, I am a little unclear as to what the best way to fix the problem is (e.g., what’s the safest way to modify the scrivomatic code in the project folder to refer to the proper directory?)

The Scrivomatic log file follows

=== ------------------------------------------------------ ===
=== Scrivomatic V1.0.30 Report @ 2022-07-09 23:48:20 -0500 ===
=== ------------------------------------------------------ ===
 Running shell: /bin/bash
 Working directory: /Users/deo/Desktop/workflow-mmd
 Initiating with Ruby 2.6.8
===------ Input Options: ------===
#<struct Scrivomatic::OPT input="", output=nil, to=nil, yaml="pandocomatic.yaml", command="pandocomatic", envpath="/Users/deo/bin:/Library/TeX/texbin:/usr/local/bin", build=false, cleanup=false, verbose=true, dry_run=false, open_log=true, data_dir=nil>
===------ Final ENV PATH: ------===
===------ TOOL PATHS: ------===
---pandoc: /usr/local/bin/pandoc | V: 2.7.3
sh: pandocomatic: command not found
---pandocomatic:  | V: 
---ruby: /usr/bin/ruby | V: ruby 2.6.8p205 (2021-07-07 revision 67951) [universal.arm64e-darwin21]
---rbenv versions:
---gem: /usr/bin/gem
---xelatex: /Library/TeX/texbin/xelatex
---latexmk: /Library/TeX/texbin/latexmk

 … running pandocomatic, please wait …
===------ COMMAND OUTPUT: ------===
Tool doesn't exist!!!

!!!---scrivomatic::runCommand() Couldn't find  to run, please supply a proper path!

Yes, this is probably the same problem, M1 users require V1.0.31 of scrivomatic. Please redownload / pull to get the latest version of the workflow zip…

1 Like

I will try re-downloading, checking the version number.

I tried running it with V1.0.31, @nontroppo, and got the same error message. I think it has to do with pandocomatic not being installed. Previously when I tried installing pandocomatic by typing gem install pandocomatic, I got the following error message in the Terminal concerning write permission:

deo$ gem install pandocomatic
Fetching pandocomatic-0.2.8.gem
Fetching paru-0.4.3.gem
Fetching optimist-3.0.1.gem
ERROR:  While executing gem ... (Gem::FilePermissionError)
    You don't have write permissions for the /Library/Ruby/Gems/2.6.0 directory

Yes, I think if you are using the built-in Ruby, you need to use the sudo command otherwise gems cannot install. I do mention that but I link it to macOS Catalina, I cleaned that bit up in the online doc. The command should be:

sudo gem install pandocomatic
1 Like