error message when try to open file

The other messages I’m seeing have different problems encountered in trying to open a file.

I started a detailed project in February of 2012. After that my computer died, but I have the file on an external hard drive because I back up regularly. But when I try to open it I get an error message that says:

"Cannot access [location/name of file].

File is not writable. Access is denied.

Auto-saves need write permission to your project."

Can you tell me what to do? It’s frustrating looking at the file on my backup drive and not being able to access it, and I’m having a terrible feeling of dread that it might no longer be accessible, even though I made sure I backed it up.


Good news! I found another backup file, and that one worked! Thank heavens.


Glad you’ve got everything sorted now! The error message indicates that the project is in a read-only state. Scrivener needs to be able to save to the project as soon as it opens, since it has to keep interface settings and all the various files in sync, so it cannot open a project that is read-only; it doesn’t mean, however, that there is anything corrupt with the project, just that you need to enable write access. Usually a read-only error like this when opening a backup is from one of two problems: the project was saved as a zip archive and you’re attempting to open it directly from that archive without having extracted it first, or your current user account does not have write permissions to wherever the backup currently is (e.g. you’ve saved it to an external and are trying to access it from another computer which has read-only access to that drive).

You can extract the project from the zipped archive typically either by right-clicking the zip and choosing Extract All or by double-clicking to open the zipped folder and then dragging out the contained .scriv project folder to another location. In cases of the read-only permissions for the location the project is stored, you can change those permissions or make a copy of the project to somewhere that you do have write access.

In some cases it’s possible that the permissions got changed on the project folder or files itself, in which case you can usually fix it simply by right-clicking the project .scriv folder, choosing Properties, and then deselecting “Read-only” from the Attributes section. Apply that to all the contents of the folder and you should then be able to open it in Scrivener, and the permissions will then get reset as they should.

Hopefully that will help should you ever encounter the problem again!