Error when accessing Windows-created file on Mac (EDITED)

My writing partner and I are working on separate NaNo projects, but we like to keep up-to-date with each other’s work and cheerlead, as it were. I’m not having any trouble accessing her project (created with the 2.0 NaNo version of Scrivener), but every time she tries to open my project (created with the Windows 1.2 beta), she gets the following error:

We share our projects via Dropbox, and I’ve tried giving her files with all of my research links deleted, but those fare no better.

ETA: I’ve narrowed it down to one of the files I’ve imported into my research folder, but I’m not sure which one is the culprit. I’ve got .pdf, .jpg, .png, and a bunch of stuff copied from websites in there.

I am having the same issue. I opened a Mac created project in the Windows version and made some changes to one of the draft files, but I can’t reopen the project now on the Mac. The project files work just on the Windows machine however.

I tried creating a new, blank project on the Mac and importing the errant project, but that did not work.

I’m having the same issue. I created my original file on Scrivener 2 on the Mac. I then successfully opened it into Scrivener for Windows and have been working with it. Yesterday I tried to open the file in Scrivener 2 for Mac, and I get the same “An exception was thrown” message when I try to restore the file to the Mac.

I tried several things.

  1. I tried backing up the windows file to Dropbox and restoring it to Scrivener (got a message saying “The Binder file for this project could not be opened … It may be corrupted or you may be trying to import a project that was created on an earlier version of Scrivener”

  2. Tried backing up the file freshly, with the same result

  3. Tried restoring from a zipped backup file - Scrivener 2 wouldn’t recognize it at all

  4. Tried saving the project to Dropbox in Windows Scrivener, then opening it from Dropbox in Scrivener 2. That’s when I got the “An exception was thrown…” message reported by blksmthson.

  5. Since Scrivener 2 seemed determined my file was corrupt, I went back to S for WIndows, saved the file to a new name, deleted all the non-draft data (all my research data, which got rid of all jpg’s, pdf’s, etc.), emptied my trash, and saved the file to Dropbox. When I tried to open it in Scrivener 2 on the Max, In got the “An exception was thrown” message

I then created an RTF of my draft folder from Scrivener for Windows, imported it into Scrivener 2, and rebuilt the entire project on the Mac, reconstructing my character files from pre-scrivener days. I’ll watch this forum until the bug is fixed before I try using the Windows version again, to avoid losing work in progress.

I’ll be happy to do any testing if needed.


I’m having the same problem. I’ve tried to open from my Mac different projects saved or created in Scrivener for Windows, but nothing seems to work so far. I even tried to open one project that was originally saved in Mac and opened in Windows. I’ve tried to open single documents projects, as well as big projects full of web pages and PDFs. I tried zipping it. I even tried to import it, but that didn’t work either. Any sugestions?