Export FDX without enclosing folder

SOLVED: The enclosing folder was caused by having the “Notes” box checked under Metadata in the export window.

Is this a bug? In an FDX file, the notes aren’t a separate file, they are incorporated into the XML file. So Scrivener only exports a single file, but puts it in a folder as though it were exporting multiple files.

When I use File>Export>Files>FDX to export a single Script Mode document from the binder, Scrivener 3.22 creates an enclosing folder with the same name as the document, and saves the exported FDX file inside.

This did not happen previously, which leads me to believe that I’m doing something wrong to trigger this behavior.

(Please do not suggest Compiling - it’s important to my workflow that I use the Export process.)

The document has no subdocuments, and I have Do Not Export Subdocuments checked in the Export options. The document originated as about 75 folders and Script Mode documents that were merged into a single document.

How do I export this file without exporting an enclosing folder?

Thanks in advance.

As noted in Chapter 25 on Exporting, in §25.2, Metadata and Options:

The export panel features the following settings in two tabs. The Metadata tab enables additional material to be exported, and will be useful if you are preparing an archival backup that can persist long beyond your use of Scrivener:

Notes: Document notes will be exported as separate files using the text file format you chose above (RTF will be used instead, when any script formats are chosen). The naming convention will be “(Binder Title) Notes”.

It has been this way for as long as there has been a way of exporting chunks of data out of various areas of the software—so I’m not sure what it is you were doing before.

Thanks for your reply. The Scrivener Manual is inaccurate on this topic.

As I posted above, the exported notes are not included as a separate file when exporting to FDX. A single FDX file is exported containing both the screenplay data and the notes data in one XML file. This is as it should be, and is the most useful configuration.

Since Scrivener only exports one FDX file when including notes, the enclosing folder is unnecessary. I expect this is an oversight, because all the other formats export a separate notes file, and therefore require a containing folder.

I hope this can get fixed, because the exported enclosing folder is unneeded, and removing it creates unnecessary work.

before, I was exporting without the Notes option checked. That exported the expected single file, with no enclosing folder.

Sorry, I don’t see anything like that on my end, and am confused as what it is be referring to. Are we talking about the same “Notes” that this checkbox would be enabling the export of: the contents of the Document Notes field in the inspector, first tab?

…before, I was exporting without the Notes option checked. That exported the expected single file, with no enclosing folder.

Oh okay. So for the record it has worked this way since v2. Even if a document does not have notes to export it still gets filed into a folder, and regardless of the file type being used for export. I suspect that the presence of any options that would typically generate sidecar files triggers a folder mode and it just goes on from there without going back and moving things around if, in the end, that presumption didn’t pan out.

I think that FDX files are different and Scrivener should treat them differently.

An FDX export will never generate a sidecar file for notes alone. The notes are incorporated into the FDX. Because of this, it is unnecessary for Scrivener to create the enclosing file for an FDX export with notes as the only active option.

If Notes is the only box checked, I think Scrivener should export the FDX without an enclosing folder.

That seems like a reasonable conclusion. It seems to me like a convenience for the developer that creates inconvenience for the user. I’d appreciate it if someday it were fixed.

It’s a bit of an aside I think, but I am trying to see this result, and am having no luck on my end. With two binder items, one with notes and one without, when I export them both I get:

Folder Name
├── One.fdx
├── One Notes.rtf
└── Two.fdx

Thank you for looking into this, it has led me to a discovery that solves the problem.

The term “notes” is confusing in this context. In my use case, Scrivener Comments are converted into Final Draft Scriptnotes within the exported FDX. Scrivener document notes are exported as a sidecar file.

The discovery is that Scrivener exports the Comments even if the Notes export option is off. That means I can export the script document with Comments incorporated without the enclosing folder.

Thanks for spending the time on this.

Ohhh yeah, comments and annotations are another setting. They aren’t considered “metadata”, and whether or not to include them is found in the Options tab. That makes a lot more sense, because I wasn’t sure how actual document notes would be incorporated into the XML, but comments definitely would.

When I export to FDX with all option and meta boxes false, comments are still exported to the FDX file.

But the logic for the comments & annotations setting is to leave them in if the setting is false. The wording is to remove them if ticked, so it would make sense if they are all set to false that they would be included.

Since Scrivener’s Comments become Final Draft Notes, it was easy for me to confuse the Notes export setting as referring to comments. I assumed (incorrectly) that in order to export Scrivener comments to FDX Notes, the Notes export box should be true.

Thanks to this exchange, I understand my mistake, my workflow is rescued and all is well.