Export to (RTF) selected Binder items revealing inline annotations (on page)

I have set up Compile to do export (.rtf) the whole project and inline annotations/comments appear just fine, but when I export (⇧⌘E) just a few selected docs/items in the Binder the the inline annotations/comments disappear. It all worked a few months ago, so not sure if something changed. Thanks.

I think I found the answer: in Compile select ‘Current Document’ hidden at the bottom/middle depending on how many docs in your full project.

Export does not use compile settings for its output, if that is what you mean. There is a setting in the “Options” tab of the Export panel itself, that controls whether inline annotations and comments appear. Could be you have that ticked.

Otherwise, yeah I tend to prefer using the compiler in Current Selection mode, like you describe—unless I’m specifically wanting dozens of files (like a full Binder backup to the disk).

Under Export options the ‘remove annotations/comments’ is not ticked, but I still don’t get inline annotations on printed page when performing ⇧⌘E (rtf) on a few binder items. I use it currently to quickly send co-writer pages with inline notes/alt dialogue etc. My needs are very simple at this point so I’d prefer just to use simple export preferably with my own choice of annotation delimiters.

It was working before because I was going to compile using ‘current selection’ and using settings below to include enclosed in {annotations} giving me exactly what I wanted. A few months ago I could do it straight from Export command and I did get inline annotation enclosed in ().

I have no problems getting both inline annotations and inspector comments out to RTF comments, so long as the relevant checkbox is off.

Perhaps it is a matter of what is doing the beholding, rather than Scrivener itself? For instance if I were to try and open that RTF file in a program incapable of reading notes (like TextEdit or Pages), they will seem to be stripped out, though they aren’t, and can be easily seen in LibreOffice, Nisus Writer Pro, Word and other capable word processors I’m sure.

Or maybe it’s that you’ve switch to use RTF for export recently, rather than RTFD (which it looks like you are using with the compiler). RTFD doesn’t support comments (or rather, no program that supports RTFD natively supports comments), so they are necessarily “flattened” to plain-text using brackets.

Umm, FYI Nisus Writer Pro supports RTFD and comments … but I don’t use RTFD so I don’t know about combining the two … perhaps I’ll give it a try.



Good to know! But that’s an unusual case. For most things, the only reason to use RTFD is to export to run of the mill macOS software using the stock text engine. Most will have not spent the considerable effort Scrivener/NWP have in augmenting that engine beyond its stock capabilities. So yeah, it looks like you can save comments/footnotes, etc. into an RTFD file with Nisus—but TextEdit ignores them, meaning most software will too.

That fixed it. I was unaware I was exporting to RTFD in Compiler so I switched to export RTFD and I got colored annotations in brackets using TextEdit. All good. Thanks.