Export to Word formatting issues

I have an entire novel in Scrivener and am having difficulty with the transfer to Word 2008.

When I export files to Word as default (.rtfd), I have to open it in TextEdit. That’s okay, but the formatting of the little extra space between paragraphs remains. Same thing with .rtf. In neither case can I get rid of it by selecting the entire document and formatting paragraph to double space, which is my ultimate goal. However, I do retain indented paragraphs.

So I go to Compile Draft and compile it as a .rtf. I still have that little extra space.

I create a Word document and copy/paste individual files from Scrivener into it (only 21 chapters–annoying, but doable). Again, I get the little extra space. I need it gone.

I’ve been through and through and THROUGH the Preferences in Scrivener, trying to find where I can eliminate that formatting at the source, but I cannot find it. If I can’t get rid of that silly extra space, I’m going to have to go back to writing in Word. I’ve lost an entire day to this issue now and am going crazy.

It sounds like you are describing paragraph spacing. You should be able to knock this out fairly easily by adjusting the Spacing preferences in the Compile ruler. Set that to “Single” is probably what you want.

To adjust the default behaviour of Scrivener, you’d need to set this up in your main preferences, under editor. Again, adjust the settings of the ruler until you have something you like.

Thanks for your reply, Amber. I believe I see where you’re speaking of, both in Scrivener>Preferences>Text Editing (and under File>Compile Draft). Both have the Main Text Attributes, then the row of Styles, Justification, Spacing, and Lists. I assume Preferences will change it for all future projects, and under Compile Draft would do so for this particular Export.

However, clicking on Spacing here and selecting other options does not eliminate the extra paragraph space. I’m at a loss.

In Preferences:Text Editing, you should see this (font aside):

And something quite similar in compile:

I created these settings by choose the single-spacing option. Okay, but say I use a generous paragraph spacing setting, and then compile with single-spacing settings. Here is the result that I get. Note the font has changed and the styling has changed. My lines have gone from 1.2x line-height with a 12pt after-paragraph spacing, to single-spaced Courier and no paragraphs spacing.

If you have preferences set up similar to my first screenshot, and you select a document in the Binder and choose Documents/Convert/Formatting to Default Text Style, does anything happen? If you still see spaces—are you quite sure they are not actually spaces, as in real carriage returns? Naturally, compile cannot do anything about that. If you document is literally spaced, it will stay that way no matter how small you make your pseudo-spacing settings.

Thank you, Amber.

The missing link seemed to be the over-ride checkbox. I’ve now successfully compiled and exported to Word, where I can make the final formatting adjustments for my critique partners.

Thanks so much!! Valerie

Fantastic. One other thing to watch out for is the a counter-override setting. Or an override of the override. :slight_smile: Each document can be set to “Preserve Formatting” which will ignore this compile checkbox you discovered. Good for poetry and other such things that require unique formatting from the rest of the book.