Exporting pdfs to Scrivener using the print menu ('save pdf to Scrivener')

I’m having trouble exporting PDFs to Scrivener. When I’m on a webpage that I want to use for my research I’d like to be able to choose the ‘save pdf to Scrivener’ option that appears under the ‘pdf’ menu when one ‘prints’ a webpage. What happens is that the print utility appears to run through the pages it wants to ‘print’ (as it would if printing to a pdf without Scrivener). However, nothing appears in the research folder of my open Scrivener project.
I’ve tried deleting the ‘save pdf to Scrivener’ file in the ‘PDF Services’ folder in my Library (as recommended in a forum post from May last year). However, that makes no difference.
When I try searching for recently created pdfs in Finder, the files I want don’t appear even to have been created. So the problem seems to lie in generating the pdf file within the Print menu rather than file location.
I’ve tried doing the same kind of export via print/ pdf/ save pdf to Scrivener using Word and that doesn’t work either.
I’m using Catalina.

Potentially, but I wouldn’t jump to that conclusion without testing other options than Scrivener as your target, first. Finder is probably not going to be the best tool for finding these PDF files—I could be wrong as I rarely use this tool myself, but it wouldn’t surprise me if the actual .pdf file is written in some hidden system temp folder that Finder is not allowed to navigate to without encouragement, and Spotlight will never index. It might even be deleted moments after sending it to the target.

What I would do is first make sure the alias works correctly, from the PDF Services Library folder itself. This is just a simple alias by the way, nothing fancy, so if you double-click it, Scrivener should open. If it does not, try creating your own alias from Scrivener in the Applications folder, put it in this folder, and rename it to “Save PDF to Scrivener”.

I can’t imagine it would be broken since you just did the steps to rebuild it, but maybe the problem is in the automatic process.

The only other thing I can think of is some kind of new security dialogue that got dismissed at some point. 10.15 is rife with inane questions like, “Are you sure you want to allow Safari to use your Downloads folder?” so maybe the first time you tried this you got a message like that, and now it is blocked? Wouldn’t know where to go precisely to fix that, but the “Security & Privacy” system preference pane is where it generally would be. Look for places where Scrivener is listed, but not checked off.

By the way, it works flawlessly on my 10.15 testing partition. I don’t recall seeing any security messages, but there are so many they tend to just get dismissed without reading.

Thanks very much for your reply.
I’ve checked the ‘Save pdf to Scrivener’ alias in Library/ PDF Services, and it does indeed open Scrivener. So that seems to be in good order.
I can’t see any options relating to Scrivener in the Security or Privacy preferences of Safari.
I’ve tried some more apps. I get the same problem when trying to ‘print’ a pdf to Scrivener from TextEdit, Preview and Firefox (as well as Word, mentioned in the original post). I’ve checked system preferences for printers and extensions, but there’s no obvious way there to enable exporting pdfs to Scrivener.
There is no relevant option in the ‘import’ tab under the sharing prefs in Scrivener.
Not sure what to do.

As far as checking to see whether it works in general, what I was thinking of is whether any other program can be a target; sorry for not making that clear. I think every program that can print will work the same when targeting Scrivener, all of this is coming through the same Mac infrastructure, so it doesn’t matter if TextEdit or Firefox is doing it. Do you have any other software installed that allows you to save a PDF to them via this mechanism? It looks like both EagleFiler and DEVONthink Pro do, if you have either of those. Maybe Evernote does?

I’m having the same problem as the original poster, except I’m on the latest version of Big Sur. The alias file is in the library which can be seen by choosing Go and typing in ~/LIbrary.

The printed file does not appear anyplace in the research folder of Scrivener. Or if it does, it’s in some place I haven’t looked. I just discovered this feature and would like to make use of it, but it simply does not work on either of my Macs.

Double clicking on the alias opens scrivener, though I always have the project I want the printed file to appear in open when I try the print/PDF/Scrivener option.

Something is happening when I try the option. A small window shows, the bar fills across left to right, then it disappears. So the file is being saved someplace, but I’ve no clue where.

What am I doing wrong?


If it helps at all with this, I don’t normally print anything as PDF to Scrivener, and when I try, nothing happens.

On the other hand I use “Print PDF to Yojimbo” on an almost daily basis. That used to have to be set up in the Services menu, but with 10.14—I think—the ability to do so disappeared. I contacted BareBones, the developers, who told me that they had changed it to become part of the App itself. So choosing “Print PDF to Yojimbo” brings up a dialog allowing you to name the document and add tags and notes.

So I wonder if this was anything to do with Sandboxing and ever greater levels of security control.