Extension .scriv in Linux (Ubuntu)

How could I associate the extension of Scrivener’s files (.scriv) with the Scrivener application?

When I click on a XXX.scriv it is opened only as a folder. If I right-click, I see “Open” but not “Open with other application”, for this extension is seen as it would be a folder. I have edited the file /etc/gnome/default.list and added “text/scriv=Scrivener.desktop” or “application/scriv=Scrivener.desktop”, but without success. So, any idea about it?

Thank you.

You actually have to open the project file inside the .scriv folder, the one which has a .scrivx extension. Try associating that extension and see if it works.

Thanks for your answer. Yes, thus it works fine… But, does it mean that I must go allways first inside the folder “XXX.scriv”? Is there no way to associate this extension (scriv) with the app? In fact, on Macs it goes without this problem. Why in Linux it seems to be impossible?

Anyway, thanks a lot for your help.

Because that’s the way OS-X works. On a Mac, it’s a “package” … what looks like an ordinary file, but is in fact a folder with multiple contents. The package format doesn’t exist on Windows or Linux, so you see the folder structure. The .scrivx file was introduced as part of the Mac version 2 upgrade in order to make it possible to use projects across platforms. So yes, if you’re on Windows or Linux, until those OSs introduce package formats, you’ll have to open the yourproject.scriv and click on or whatever the project.scrivx file inside.

Mr X

Thank you very much for your explanation, Xiamenese. I understand now the problem. I naïvely supposed the fact that OS-X and Linux are unix-like systems meant that the format of the app had to be more or less the same. So, either Literature and Latte prepare totally different packages for each system other we have to look inside the package… Isn’t it? Well, it doesn’t matter. I prefer this option than not to have Scrivenr in linux at all.

Best regards and thanks again.

No, the package format is down to Apple. Many OS-X apps use it, including Pages, I believe, and Final Cut Pro X and so on. Because they appear in the finder looking like files, most users consider they are files and have no need to know otherwise. If you right-click on one of your Scrivener projects on your Mac and choose “Show Package Contents” from the drop-down menu, you will see that under the hood it is exactly the same as the project on Linux … it’s just all hidden in the package.

Mr X

Edit … addendum: and if you start a project on your Linux machine, and open it on your Mac, you’ll find that it will appear there as if it were a single file.

Actually windows does something similar (or rather the MS bloatware) with things like mail PST, docx, and a few other extensions. There are hacks to extend it to other extensions as well.

But for linux, of you really want "one click, use a shortcut in your window manager. Just be sure to set set the “run in” directory to where the scrivx is located.

Thanks Jaysen and Xiamenesa!
Knowing that that’s normal, I have no problem looking inside the folder and clicking on .scrivx. I have asked because I thought it was a problem with my Ubuntu installation. I knew that in Mac all the apps are packages, but I didn’t suppose that this package-format had not been implemented in Linux and therefore I hoped the same response by clicking on the scrivener’s file.

If I may jump in and add a word of caution: I was one of those happy Mac users. Since the Mac package file doesn’t readily expose its contents, there was never the opportunity to interfere with its contents. HOWEVER this is a common source of trouble for Win/Linux users, who see that neat .scriv project folder and get curious about all that other stuff in the folder besides the .scrivx file. Resist any temptation to add/alter/revise any of those files. They’re all of them, support & content for your Scriv project. Leave 'em RIP [rest in peace] :mrgreen: .

Thanks for your tremendous admonition… I’ll retain my dangerous inquiring about these files…