External Folder and Footnotes/Comments

I’ve attempted something, and perhaps it’s not something I should attempt.

I’m trying to use the external folder sync option so that I could work on my tablet while away from home. The tablet is a Samsung S6 Lite. The editing software is TextMaker Office. The external folder is on an SD card that I can carry with me.

And after syncing, I can see that the files are synced correctly as RTF files, and I can access them through the software, edit them, and save them again. However, my footnotes and comments do not appear in the RTF files and they are missing when I return to the desktop and sync the edited documents.

How do I preserve these footnotes and comments? Should I use inline only?

My guess would be that TextMaker Office is using a different approach to handling footnotes and comments, in a way that Scrivener isn’t programmed to understand. It could be helpful to us if you create a little test document in your binder with a comment and a footnote, sync it, edit both notes in TextMaker, and then attach a copy of this edited file—before syncing in Scrivener—so we can see what the internal RTF codes look like. If what they are doing is standard, then we should probably fix our parsing code to be aware of it.

You could also check LibreOffice/Word and see if they show up there. That wouldn’t prove they are “normal” though, in that those two programs probably support way more contingencies and weirdness than we do anyway—but it would show that at least TextMaker isn’t completely off the rails and doing something proprietary nobody else can work with.

Generally, this should work fine though. At least with LibreOffice, I can edit, add and remove comments and footnotes and everything comes back over as expected.

1 Like

Thank you so much for the very fast reply! I’ve attached the two files I found in my external folder after editing with TextMaker Office. They’re in a zip format because it wouldn’t allow me to upload either the .rtf or .bak file formats in this editor box. If there’s another way to send them without zipping (if you prefer that), let me know.

I’ve not tried syncing with the desktop since opening and editing on the tablet. I noticed on the tablet that I could see the comment and the inline footnote (moved down to the footnotes), but the inspector footnote was missing. I’ve also attached a screenshot in case that’s helpful.

I will try LibreOffice–that’s a great recommendation as well. Thank you! It’s not available as an Android app, but there’s an approved app based on it called Collabora Office.

Draft.zip (2.6 KB)

If that doesn’t work, perhaps have a look at JotterPad. It can be used for free, and perhaps it handles comments and footnotes (that, I don’t remember).

1 Like

Okay! I think I see what is happening now. Initially I tested with the RTF document provided, and everything worked flawlessly.

But then I realised that this “bak” file you also sent in the .zip might be getting put into the sync folder as well. So for the next test I placed both the .rtf and the .bak files into the sync folder, ran it, and got an incomplete result.

The problem isn’t that comments/footnotes are being deleted or ignored, it is that Scrivener is getting confused over there being multiple documents assigned to the same binder item. It ultimately, in this case anyway, imports the backup file as the “latest”, but in most cases it will probably be a few editing steps older than the .rtf file.

If there is a way to disable the creation of .bak files in the same folder as the edited document, in TextMaker, that would be the way to go. Otherwise I’d make an effort to clean them out before syncing, upon return to the desktop.

1 Like

Fantastic - I’ll take a look at the options in TextMaker and if I can’t prevent the .bak files, I’ll just put an item on my workflow to get rid of them before opening/syncing the project on desktop. Thank you for all you do to help us with this!

Editing to add: I’ll try Collabora first, because I think TextMaker shifted my inline footnote to an inspector footnote when I synced back to the desktop. It’s got something weird going on under the hood, maybe. Still, thank you!

Just updating here on my progress in case it’ll be of use to anyone else down the road:

I was able to turn of the .bak files that TextMaker was creating; it’s something to set in the options menu.

Collabora does not work. It did the same thing Word for Android did with .rtf files: telling me it could not edit them, but offering to create a duplicate that it saves in a different format. I still have not found a free app that offers editing of original .rtf files.

If I sync the files as .txt, TextMaker works pretty well. It doesn’t delete my inspector footnotes (as it was doing with the footnotes in .rtf files). They aren’t visible while editing within TextMaker, but they are still present when I return to Scrivener on Windows. I can also create inline footnotes by typing them inside of double braces {{like this}}.

So for now, I’m attempting to work on my tablet with .txt files, using only inline footnotes. It gets goofy with bullet points or numbered lists, but otherwise is okay. It’s a 90% good enough solution for now–I can type away and format what I need to when I get onto Windows.

I just tried to run a test with comments and footnotes on JotterPad… to realize that indeed, it doesn’t handle RTF, contrary to what I recollected.

Perhaps this would do better:

I am trying it as we speak. The source I got the info about it from says it handles RTF. With any luck, comments and footnotes will work.

1 Like

Arrr… False advertisement…
Says it is free,
it is not.

Annual fee to be able to edit the documents. (60 CAD$)

But from what I can tell the footnotes work. (Can’t say about the comments, app is locked for editing, and I don’t want to get into the subscription/trial/future-payment process.)

Doing a bit of research, I am surprised that Collabora didn’t work for you…

(I will try it for myself later.)

1 Like

By the way.
As far as a mobile solution goes, it of course depends on how much you need it and the amount you are willing to inject in the “project”, but personally, after trying to conveniently work on Android for a while, my solution was to buy a Windows tablet.

I run the full version of Scrivener on it. :slight_smile: It works wonders.
So now I can take Scrivener with me anywhere I want.

I bought a license of ComfortKeys (which I use as a touch keyboard and for macros – since I don’t always use a mouse), and after a bit of learning and configuring, I was all set.
I can now use it as a laptop (the detachable sleeve has a built-in keyboard and touchpad), or as a tablet, and the whole thing is no bigger than a book. :wink:

Cost : under 300 CAD$
Not really knowing what I was getting into, I bought the tablet on Amazon, my choice based on the price of the thing more than on its specs. (Still, I think I got really lucky, and landed quite a deal.)

1 Like

So, I had discarded Collabora because it wouldn’t open an editable .rtf from the file manager. But after your comment, I got curious and tried opening a .txt from the file manager, and it gave me the same error: “This is read only, would you like to create a copy to edit?” (or something to that effect). Then I tried opening the .txt from within Collabora, and it gave me a warning about formatting limitations, but let me open it. So, I’ve just tried opening an .rtf from within Collabora, and voila! I can open and edit it. It gets funny with formatting on the roundtrip, and adds asterisks for all my footnotes, but it’s better than TextMaker.

1 Like

Wonderful :slight_smile:

First thing you should do, is, in my opinion, to edit the file just a tad, and then see how it looks when brought back into Scrivener.

Leave in whatever formatting marks looks weird to you.

…And then, of course, tell us about it. :wink:

Hi Amber - Thanks again for your help. I’ve done some more checking on things and here’s what I’m finding: TextMaker is not seeing the footnotes that Scrivener creates with .rtf files. This is only true with .rtf created through “sync with external folder” and not true for “export files” rtf files. I’ve contacted them to ask what might be causing this–TextMaker not only does not show the footnotes, it must actually erase them, because once I’ve opened it in TextMaker and edited it there, those footnotes are gone.

For now, it’s working fine with formatting and all the rest as long as I use inline footnotes only.

Well, I tried, but I just couldn’t get comfortable with Collabora, so I’m back to TextMaker - as I commented to Amber, it’s working with everything now in .rtf except for inspector footnotes.

I also had to adjust the options in Scrivener under import/sync to import all footnotes as inline footnotes, because TextMaker treats inline footnotes as real footnotes, then Scrivener was seeing real footnotes as inspector footnotes, then on the next round of edits, they were getting destroyed by TextMaker, which seems to destroy inspector footnotes in .rtf files created by Scrivener during external folder sync (but not during “export”). It’s a very strange problem, but I’ve contacted SoftMaker about it to see if there’s a fix on their end.

I cannot explain why you are getting a different result from an exported (I presume this to mean File ▸ Export ▸ Files...) .rtf file versus one created via sync. In my testing the two files are essentially identical.

There is a difference between inline and inspector footnote export though, in that with inspector footnotes we are using a special form of syntax that designates the RTF control where it refers to placing text at a different destination than the source. It’s meant for programmers writing parsers to use if they do not support a broad range of the RTF format. A tool that does not understand footnotes at all should skip over the content entirely rather than printing the footnote text right in the paragraph. Without that marker the parser could optionally fall back to printing the text inline instead of “at the destination” (bottom of the page in this case).

While it is odd that we are using that control marker for one type of footnote but not another, it shouldn’t make a difference to a program that can read footnotes. What is further odd about it is that, as I understand the RTF specification, one should use the marker on footnotes unless the desire to allow the reading program to print the text inline (it isn’t a hard rule). Hence the inline annotation is the one that is, technically speaking, not following that practice while the inspector footnote is using good practices (and incidentally the same good practices a program like LibreOffice would use when indicating footnotes).

This is all rather technical, I realise, but if they have questions about it, feel free to copy and paste this to them. I’m not an RTF expert, and might be reading the specs wrong, but I’m pretty sure {\*\footnote{Blah blah}} should work better if anything than {\footnote{Blah blah}} (which is how inline annotations, the ones that work better, are printed).

1 Like

Very helpful! Thank you!