Extra windows when in Composition mode

Hi all,

I’m using the latest Scrivener ( on the latest Windows 11 and I’ve been noticing this weird behavior for some time, on all my computers (a Surface Pro 9 [edit: with Intel i7], a custom desktop PC and an ASUS ROG Zephyrus G14, [edit: both with AMD CPUs & GPUs]). Whenever I’m in Composition Mode (full screen) and I press alt-tab, I see three windows: two are identical, showing my Composition mode and one looks like a title bar only (see screenshot).

All of them are clickable and do the same thing: I can switch to and close Scrivener clicking whichever I want.

Moreover, the small one, which looks like a title bar, stays in the alt-tab switcher even after I exit Composition mode and even after I quit Scrivener. Looking in the Task manager, I still see a Scrivener process which I have to kill. But even after killing that, I still have it! The only way to make the little thing go away is to reboot the computer.

I initially thought it’s a small problem at my end, but after seeing it happen on all my computers, I’m guessing there’s something wrong I should let you know about.

So, briefly:

  • open Scrivener and a project: everything’s okay;
  • switch to Composition mode: I get 2 windows in the alt-tab menu and a third looking like a title bar;
  • close Scrivener: the 2 windows go away, the title-bar-like stays;
  • end all Scrivener tasks in Task manager: the title-bar-like stays;
  • reboot PC: the title-bar-like goes away.

It happens all the time on all my computers, even after a clean reinstall (both of Scrivener and of Windows).

It’s perhaps worth adding that the whole problem appears after 1-2 minutes of switching to Composition mode, not instantaneous. Also, if I never use Composition mode, everything’s fine.

Alt+Tab is Windows operating system shortcut to switch between running applications. (You probably know that already.)
I tested it on my Windows 11 laptop and don’t get the same result.
How do you start Scrivener, from the Start menu or Taskbar, or from File Explorer? I start mine from the Start Menu. The Taskbar would have the same effect as both are shortcuts.

I start Scrivener from the taskbar, where I have pinned the application.

I’m assuming you’re thinking about a duplicate launch in some way or that somehow the process ends up duplicated. Which I don’t think it is the case, as the Task Manager only shows one process (the one I have to kill with End task to have the small title-bar-like window disappear).

Also, I don’t know if it is relevant, but when Scrivener is in fullscreen (composition) mode, I don’t get the little dot indicator underneath its icon in the task bar, I can only see it in a windowed mode. I guess it depends from app to app, because for example, the Microsoft Edge browser has that dot visible both in fullscreen and windowed mode.

Edit: Curiously enough, after a computer restart, the problem hasn’t reapearred so far. I’m in Composition mode and keep pressing alt-tab to switch between running applications and Scrivener is behaving well so far. I don’t know what’s changed, I have the same running applications (Edge, WhatsApp, Telegram, Aquile Reader, and One Note).

I tried running Scrivener in another Desktop on the same machine.
While I can get another project to run in Desktop 2, the open project won’t launch again on Desktop 2 if already open on Desktop 1.
So that’s not a possible answer.
The dots you referred to are normally pending security update indicators, though I’ve never seen it with the Scrivener icon.

No, it’s not that. Maybe I’ve explained it wrong. It’s the open app indicators, smaller when the app is in the background, larger, like a line, when the app is focused (in the foreground), see the image attached.

1 Like

Just an update: After a couple of short writing sessions when the bug didn’t occur, it reappeared. I don’t know what triggered it, I didn’t do anything that I don’t normally do (I even have the same programs opened and the same window configuration).

So yeah, it’s still there, whatever it is.

And it’s weird if nobody else has ever seen it, as I swear I’ve experienced it even right after a clean install of Windows and Scrivener.

If there’s any L&L dev here who would like more specifics or even a memory dump or some logs, please let me know. I know it’s not something major, as there are no problems in its actual functions, but it still bugs me. Could it be a Windows bug, perhaps something to do with the Desktop Window Manager?