F keys and Logitech K811 keyboard

Just upgraded to Catalina (fresh install on new mini).

Scriv generally OK, but in trying to reinsert my custom keyboard shortcuts for the f keys of my Logitech K811 keyboard, I can only add them as fn-f7 etc, not simply f7 etc as I used to have.

I notice that the MacOS system pref for Keyboard no longer has the "“Use F1, F2, etc. keys as standard function keys” entry in the Keyboard tab, but my Logitech Options panel for the keyboard does, and it’s ticked.

Not a huge problem—I mean, only one extra keystroke—but it’s frustrating where something that should be do-able is, er, not do-able. And my muscle memory keeps making me hit F11 (only) for Layouts and get sound mute instead, and so on for all the other f keys I’ve set to Scriv-specific tasks,

I’ve just checked Preferences > Keyboard > Keyboard on my 2015 iMac running Catalina 10.15.4 and it has the “Use F1, F2 etc. as standard function keys”.


Xiamenese, are you using an Apple keyboard? I believe the Catalina pref panel now shows the “standard keys” message for Apple keyboards, not for others, like my Logitech board.

I believe this is handled via the Logitech Options software that you can install with the keyboard, though you may want to double-check with them. My recollection when setting this up for a computer last summer with the K480 was that there weren’t that many options, and neither the K480 nor K811 can customise those keys, but I think just the toggle to act as function keys by default with Fn for the special behaviour is still available.

MimeticMouton, yes, as I mentioned, I have to use Logi Options for the standard-keys setting now, as the Catalina Keyboard pref panel no longer offers this for non-Apple keyboards.

My problem, slim though it may be, is that where with the previous version of the OS I was able to use the F-key-only for my custom shortcuts, now I have no choice but to add a modifier key for this to work, in my case the fn key.

Sorry, but it’s not a case of no longer offers for non-Apple keyboards. It does offer the function for 3rd party keyboards that meet the published Apple specs. I have a number of 3rd party wired and wireless keyboards that work as expected with the keyboard pref panel.

The issue is Logi have a history of making keyboards that incorporate their own ‘tweaks’ that dom’t always play nice with operating systems.

Unfortunately your only recourse is to chase Logi. Neither Apple nor L&L are the point of contact to try to resolve.

Astaff, glad to hear your collection of keyboards are serving you well. I think the 811 keyboard met Apple’s specs at some point, because the setting in the pref panel was available pre-Catalina.

I like my Logi keyboard a lot, so I’ll put up with the slight inconvenience. I posted here in case someone had similar experiences that might help me try something I hadn’t thought of. I usually find the folk round here help when and where they can. Anyway, l’ve raised a ticket with Logi, so will see what they can do.

Yeah, sorry, I read the thread in two parts and missed that you were already working with the Logitech software settings. Unfortunately I’m not sure what else to do to get around it. Karabiner Elements is my go-to for this sort of thing, but as to whether you can get it to work with the Logitech Keyboard for this particular issue, I don’t know. Logitech’s ‘fn’ key doesn’t output a key code at all, so what you’re able to modify from the Mac side will be more limited. You might find a means to take the input from the external keyboard and translate it into something else though. Or maybe something like BetterTouchTool can turn the K811’s “Volume Down” into “Manage Layouts” in Scrivener. :slight_smile:

Logitech support were very helpful on this, and told me the problem revolved around Apple now requiring user approval for all KEXT (driver) loading.

I quote: “To allow KEXT loading, please open System Preferences and navigate to the Security & Privacy section. On the General tab, you should see a [Logitech related] message and an Allow button. In order to load the drivers, click Allow. You may need to reboot your system so the drivers are properly loaded and the functionality of your device is restored. (NB As set by the system, the Allow button is only available for 30 minutes. If it has been longer than that since you installed Logitech Options, please restart your system to see the Allow button under the Security & Privacy section of System Preferences.)”

“For Logitech Options, you need to perform this operation if you’re using following devices:T651 Rechargeable trackpad
Solar Keyboard K760; K811 Bluetooth keyboard; T630/T631 Touch mouse; Bluetooth Mouse M557/M558.”

That fixed it for my K811 keyboard. Now, when I have “Use all F1, F2 etc keys as standard function keys” checked at Logi Options, I can use the F keys the way I like—in other words F11 alone to bring up the Layouts panel in Scriv, for example, rather than fn-11 (and fn-11 gives me sound mute on the much rarer occasions when I might want that).

Thought I’d post this conclusion in case others with a similar prob search and find this.

Glad you had a happy resolution! And that you had a positive experience with Logitech support. I can’t say mine was nearly as helpful, so this is nice to hear.