File not compatible... "Unsupported Project File Format""

I use Scrivener on OSX, Windows and, now, iOS. Just fired up the iOS version, synced with Dropbox without any problems and it’s picked up my Scriv projects. When trying to open them, though, I get the incompatible message. No probs: fired up Scriv for Windows (SfW), which is what I use most of the time nowadays, freshly updated to the latest version, and saved off as a new file version. Went onto the ipad, synced, new files appeared and… still incompatible :confused:

As a test, I made a new file in SfW, synced everything and that one ‘did’ open on the iPad with no problems so what am I missing??
(Admittedly, haven’t had a chance to go through all the documentation as yet, was just wondering if I was missing something obvious…)

Cheers all!

p.s. SO happy it’s now on iOS, though. Love it!

You’ll need to update your desktop versions to 2.8 for macOS and 1.9.5 for Windows. Use Scrivener > Check for Updates on macOS and Help > Check for Updates on Windows, or download the installer directly from our website. Once you’ve got the updated versions running, they should open your iOS projects without issue.

Incidentally you can open a file that has been changed on iOS with Scrivener for Mac 2.7 and it will open fine but you won’t see the changes.

Already did that, yesterday. It’s what I meant when I said


Also, the problem is with my SfW files not opening in iOS, not the other way around… Sorry if that wasn’t clear.

Sorry, I must’ve glazed over! So the incompatible message is when trying to open the project on the iOS version? I’d double-check that the dropbox sync has completely finished for all the projects from the desktop. If not all the pieces of a project have completed uploading to the server, they won’t be there for downloading to iOS, and the project would be incompatible. Given the way that Dropbox uploads individual files at a time, you could easily have ended up with some projects completely synced but others still with missing pieces.

I’m having the same issue, also with having updated to OS X 2.8. And my files say they are all completely synced.

That’s right. The actual message is “Unsupported project file format” with the body text claiming it’s from an older version of Scriv and suggesting I update it in the latest version of Scriv for Mac or Windows. Which I’ve already done.

The files are definitely synced with Dropbox. Fully uploaded from my PC.

… and you are not using the “File -> Sync to… External folder” command? You are using “Save as…”?

Nope, only just noticed that. I’ve been using the regular “Save” function which then syncs with Dropbox.

Using the standard “Save” function has worked perfectly with the test file I set up… Just not with my older, and more established, project files.

And those files open perfectly in 2.8? Have you tested to Save as… with a new name in your “sync”-folder?

As I said, I’m doing this in the latest version of Scrivener for Windows, which they open fine in and, yes, I’ve tried saving with a new filename to test. Still isn’t working.

Could you fix a screen shot? To show what it looks like?

You have done what Megan describes?

I’ve done what Megan describes. Setup was fairly straightforward, to be fair.

Just to reiterate - the files have been updated to be worked on in the latest version of Scrivener for Windows and then “Saved As…” new versions.

From that dialog it does seem like you are trying to access older project files. Could there be a mix of new and old file formats in the Dropbox folder which is confusing the iOS app?

There really shouldn’t be. I deleted the old files, which had been converted to ‘backup’ files, anyway. All the files there are the new files, saved off as new from the latest version of Scriv for Windows.

I only have one .scriv file in my sync folder, which has been saved in Scrivener 2.8 on the desktop, and am still having Phil’s issue.

Really weird.
But as usual, there is either a perfectly simple explanation, something you have done or not done, but which you momentarily have forgotten, or there is some bonkus with the app. Have you tested deleting and re-installing the iOS app?

Yep. No difference.

Hi – last night I had several Projects which converted fine as far as the new Scrivener Windows was concerned, but got the same incompatibility alert as you people have been seeing. Many more converted fine, were compatible. All were synced in the normal way to my iPad 2, which with the latest Apple release 9.3.3 really likes Scrivener iOS.

I discovered what seemed to be the problem in the not-quite-converted projects, and put up a message right away in the Scrivener Windows bug area, hoping support would pick up on it – soon I’m sure. So here are the problems and fixes I found:

  1. In some past we could use direct links to web pages in Resources – they’re not offered anymore, and at least the latest Scrivener Windows takes a literal forever to open them – you will have to wait minutes, and with several false finishes. Once you have the web page sully loaded, you can click the link at the bottom, to open it in your normal web browser – be sure to do this. Then Trash the item, via Shift-Delete. Then without touching it, thus restarting the process, Empty Trash, which is available on the Project Menu. Then copying the url from your browser, Import Web page, choosing for best results I think PDF from Webkit. Now you will have a safe Resource which also works offline, but carries the link also so you can open the original when connected.

You’ll have to do this for each ‘web link direct’; Resource you have, but then Scrivener iOS will like the Project, after a few minutes online to be sure Dropbox has transferred it. Unless…

2.The other thing which can cause rejection I am pretty sure, is also pretty wierd. This is to have a Scrivener item with an unusual font in it. In my case this was a very strange handwriting font, Jabana Alt Extra Extended Light, for heaven’s sake. Not sure how that ever got in the project, but whatever the reason, the cure is to select All in the Scrivener item, and change the font to something more normal.

With both these fixes done as appropriate, plus a little wait to let the updates flow through the internet. all of my projects in trial opened fine and work fine in Scrivener iOS.

Which is simply great itself, comfortable, as you probably know. I hope these fixes get you on the road to comfortably using it. The item in Windows bugs should get the converter to be more robust when the team can get to it.


Hi everybody,

I just solved my problem by re-saving the file with a new name in the sync folder.

Thanks so much for the attention to this and THANK YOU FOR THE APP! It’s so gorgeous.