Find and fix uneducated apostrophes

Is there a way, within Scrivener 3, to find all of my “uneducated” apostrophes in my novel, so that I can fix them? My best approach at the moment is to compile to a LibreOffice doc and then search the output doc. (The uneducated apostrophes do not get corrected during the compile.)

(Note: if I try to do a “find” for apostrophes, I have not found a way to put an uneductated apostrophe in the find field. Even cut+paste from elsewhere does not work.)

Thanks in advance for your assistance.

By “uneducated apostrophes” do you mean straight ones, i.e. ’ ?

To enter a curly—presumably “educated”—apostrophe in any field, the keystroke is opt-shift-] A left single quote is opt-]; left and right double quotes are opt-[ and opt-shift-[ (N.B. the differences aren’t clear in the font used on this forum!)

Have you set Scrivener > Preferences > Corrections > Use Smart Quotes (“ ”) in New Projects? I believe that includes single quotes and apostrophes, but I have it turned off, preferring to sort those things out in Nisus Writer Pro post-compile)

Otherwise, right click/control click on the compile format you’re using and choose either “Edit” or “Duplicate and Edit” as appropriate, go to “Replacements” and set it up so that each of the straight marks is replaced by it’s curly equivalent in the compile process

HTH :slight_smile:

Mark

Does Transformations > Convert Quotes to Smart Quotes help?

Stephen

Mark,
To be clear, the problem is that I had a bout a hundred straight apostrophes in my novel as a result of cutting and pasting from earlier drafts on another device. The problem is NOT how to enter an educated apostrophe.

Stephen, your solution works for the current document only. My novel consists of a few hundred documents, It did save me a little time to find each apostrophe in LibreOffice, then find the doc in Scrivener 3, and then traqnsform all the apostrophes in one doc at once. I’d still like a more global solution.

I can’t check this right now, but I would expect that you could load all your documents into a scrivenings session, select all, and carry out the transformations that way.

My apologies; I read you as being unable to enter an educated apostrophe in a Find field. I have Smart Quotes turned off, so I can enter the straight ones in Find fields with no problems; also for me copying and pasting one into a Find field works perfectly … that is on my MBP running 10.13.6.

On the iMac, running 10.15.7, I have just found it uses curly ones, even though it is switched off for new projects, but I’m working in a pre-existing project. On investigation, Edit > Substitutions > Smart Quotes was switched on, which it shouldn’t be. In spite of that, the regular keystroke entered a straight apostrophe in the Find field.

Both my machines are running this afternoon’s working version of 3.2. For some reason 10.15.7 turned it on, while 10.13.6 didn’t!

So I don’t know why it doesn’t work on your set up. Also, I can confirm that opening the manuscript in Scrivenings mode should work to do the replacement within all the sub-documents as @mbbntu said.

Anyway, apologies.