First experiences with 1.2

This is what I’ve encountered so far with iOS version 1.2…

When I go to Apple’s Settings/Scrivener/Editor, it crashes.

I use only AirDrop to transfer from iOS to my Mac. Now it says I need an app from the App Store. When I select the App Store, it tells me Scrivener, which is on my iPhone from the App Store, is not available in my country. I live in the United States. If I select use the files app, that won’t work either. The only other option I have is decline. This might be something in my phone settings. I’ll continue to work on this and see if the AirDrop issue is on my end.

I’ve experienced other crashes.

Hi, @txmccoy! I’d like to work in with a contrary experience. I’ve had no problems with my iPhone 8 Plus nor with my iPad gen 6, running iOS 12.4.1. I’ve tried both your scenarios, and both work smoothly. (BTW, I’m running Mojave on my Macbook Air 11.) I’m also having no problems with Dropbox sync, which is another bug that has surfaced.

This is not to deny your experience! But it will be helpful to me to learn how your setup differs from mine. Do I need to avoid upgrading to iOS 13 for a while? Do I need to not buy a newer model iPhone until this is resolved? Should I avoid upgrading to Catalina? (Not that I would—I avoid upgrading MacOS until at least 10.XX.1. :wink: ) Please, more details will help both the dev team and other users.

Thanks, Silverdragon.

I apologize, I should have clarified in my original post and said I’m running 1.2 with iOS 13. I had zero problems before upgrading to iOS 13.

I’m not sure where the issue lies. I tried deleting Scrivener and reinstalling it. Nothing is working.

For now, I’ll let the dust settle on things and do my work on my MacBook Pro. I’m sure it will all work itself out with subsequent versions.

Thanks for jumping in.

Gotcha. Is that Official iOS 13 Release ? shudders Glad I don’t have Automatic Updates on…


Ick. No upgrade for me for a while…

IPhone X on 13, I get the same issue as OP. IPad Pro 12.9 with 12.4.1 works fine. Both on 1.2

Yeah that is a real bummer. AirDrop is what I used myself for ages, but it became unreliable in 10.12, and then it worked toward the latter stages of that development cycle—and now it doesn’t work again. We’ve been over every little setting and recommendation from Apple, and it all appears to be correctly registered, but no dice! My guess is that Apple forgot package formats exist… again.

But my experience with the Files choice is better than yours! For me, that brings up sheet that asks which folder to save it in, and Scrivener’s storage folder will be right there for me to target. Upon returning to Scrivener the project is successfully transferred. So it’s one or two extra taps—but it works well! I’m not sure why that isn’t working—in theory Files should accept any type of send. Are other types of files working with it?

Regarding the Settings crashes, I don’t get that myself, but Settings was a bit of a nightmare. They broke a lot of stuff, things had to be reorganised merely to avoid crashes with second or third-level menus, etc. Hopefully a reload sorts that out for you though.

I can confirm this.

Is this only on the iPhone for you? Unfortunately I can’t test iOS 13 on that device. For the iPad, Settings is working fine though.

Yes, it is my only iPhone. My new iPad Pro 11" arrives tomorrow.

Here’s an update. I stripped my phone and reinstalled everything. The same crashes others have reported occur. But now that I have the default settings in place, I can AirDrop to the Files app and, drumroll please, open the project right into Scrivener. After I work on it, I can, using the Files app, copy it back into the original iCloud folder and open it with my Mac. It is amazing. I’ve tested it a number of times and in different ways and it’s flawless.

I’ve installed iOS 13.1. I’ve checked a few things and it appears it has solved all the crash issues I’d encountered before. Yeah.

Resolved here also with 13.1

Thanks for the confirmation! Good to hear they fixed at least one of the Settings bugs. :slight_smile: