First Line Indent

I’m having trouble finding the options for this. I tried using the sliders at the header, but it reverts any time I flip to another document or switch to the Scrivenings view. I can’t seem to find an option for this. Anybody have any ideas?


Hello Nonny,

I am having trouble replicating the error. Every time I switch document or return after entering edit Scrivenings mode, the first line indent remains. I didn’t have to, but have you tried going to Edit > Options > Editor and setting things up in there?

All the best,

I have experienced the same behavior as Nonny, on two different computers.

I tried using the Options dialog box, but that also has some weird behaviors, and did not fix the indentation problem. (It doesn’t appear to save my changes to the font and font size.)

Further information: I have tried this on a Windows 7 64-bit machine, and a Windows Vista 32-bit machine. I have tried it with copying and pasting text from a document, as well as typing new text into a blank project. I’ve used the novel template and the blank project template.

Often, in addition to the indentation reverting, the font size reverts to 8 point. Both the indentation and the font size behaviors happen sometimes when switching between texts or folders within a project, or after closing and reopening a project.

Hope this helps track it down. Thanks.

Thanks Mankindof,

Lee has released an update addressing some of the reported bugs, with many others being on the list!



Thanks David,

I just tried Lee’s latest update, and that did not fix the problem. Interestingly, when I opened the RTF file in Word, it displayed properly: correct font, correct font size, and correct first line indentation. When I opened the RTF file in Wordpad, it had the correct font and size, but no indentation.

So, for fun, I tried setting the indentation in Wordpad and saving the RTF. When I opened the project in Scrivener, not only was the indentation reset to zero, the font had changed to “MS Shell Dlg 2” (from Times New Roman).

There’s definitely something funky with the way the editor is handling RTF tags.

For fun, I tried this: I created a new doc in Scrivener, set the first line indent to about half an inch, saved, closed the project. I opened the RTF file in WordPad: no indentation. Opened it with Word 2003 SP3: correct indentation. Reopened the project in Scrivener: no indentation, font size reset to 8. At this point, every time I open the file, Word displays it correctly, WordPad displays correct font size, but no indentation, and Scrivener shows the wrong font size and no indentation.

When I open the RTF file in Notepad, I can see the RTF tags, and I see “\fi700” which should be the tag that sets the first line indentation. At best, I have only a cursory knowledge of RTF tags, but I tried some further investigation:
I opened the file in Notepad, copied the entire contents, including RTF tags. They look like this:

{\fonttbl{\f0\fnil\fprq2\charset0\ Times New Roman;}}
{\author Unknown}

\pard\plain \fi700\ltrch\loch {\f0{This is the third attempt at checking the indent.}}}[/code]

Then I pasted into a new TXT file in Notepad, renamed it to an RTF file, and opened it in WordPad. WordPad still did not show the indentation, so in WordPad I changed the indent and saved the file. Opening the file in Notepad, I see the following changes to the RTF tags:

{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fprq2 Times New Roman;}} {\*\generator Msftedit;}\viewkind4\uc1\pard\fi720\lang1033\f0\fs24 This is the third attempt at checking the indent.\par }

WordPad and Word now both display the file correctly, but Scrivener’s editor displays the wrong font (back to MS Shell Dlg 2), correct font size, no indentation.

So, not knowing enough about RTF tags I’m going to leave off my tinkering now, but on the off chance you and Lee would find it helpful, I’ve pasted everything here. It seems like an RTF tag handling problem in some way, but my Code Fu is not strong.

Thanks again Mankindof! I am sure Lee will greatly appreciate your thoroughness. :wink:


The previous message had some great technical info about the RTF files, so this may not be necessary, but I’ll report my experiences with the first line indent problem using the new updated Scrivener.exe

I also have this “first line indent” problem. I’ve documented a sequence of my experiments below. The only thing that seems consistent is that new scenes I add have the default indent from my Options, Editor settings. However, it seems impossible to made a first line indent stick in a scene that opens without one (all the scenes in my work in progress)

Here’s the sequence, using the new Scrivener.exe I installed half an hour ago.

  1. Opened my project in the new Scrivener.
  2. Went to Edit, Options, Editor. Checked that the indent is set to .5 inches, fond set to Verdana 12.
  3. Saved preferences in Editor options - I did this because I didn’t see any Save or Apply button in the editor options, so wanted to be sure it my options were recorded.
  4. Went to one of my scenes, went to bottom and typed new lines - no indent. (However, when I create a new scene there is an indent)
  5. Went to first scene in Draft folder (scene #1), selected “All” and used the ruler tab to indent. Indents appeared
  6. Went to scene #2 in Draft folder, selected all, used ruler tab to indent. Indents appeared
  7. Went back to scene #1 - NO INDENTS
  8. I decided to try saving the document before leaving scene #1 (select all in scene, indent, Menu File–> Save).
  9. Moved away from scene #1, moved back - it WORKED! (but see #12)
  10. Changed indent on several scenes, saving each time before moving - they WORKED!
  11. Tried changing indent on two more scenes WITHOUT SAVING - they WORKED!
  12. Went back to scene #1 - NO INDENTS. They were GONE!

I’ve tried opening the RTFs in both Word 2007 and Atlantis Word Processor. The indents appear, although they do not appear in Scrivener.

I’m using Windows 7 64 bit.
I hope this helps track it down.


Great Vanessa - thanks for so much detail. Greatly appreciated.

I’m happy to help. You guys are doing a great job!


Vanessa’s description is exactly the behavior I’m seeing.

I’m using Windows Vista 32 bit, if that helps any.