[Fixed] Export as Zip crashes Scrivener iOS


I was happy to find out in the Scrivener User Manual section 12.1.2 that I can use AirDrop to share Scrivener projects between macOS and iOS (I do not want to use Dropbox).

Following the first 3 steps from the manual, Scrivener for iOS crashes for me every time while it prepares the Zip archive:

  1. On the device, from Scrivener’s main project screen, tap the Edit button.
  2. Select the project you wish to send.
  3. Tap the “Share” button at the bottom of the project list.

Caveat: I am on iOS 10 Public Beta 2 and cannot test on an iOS 9 device, so this might as well an issue on Apple’s side.

This works fine for me on iOS 9. Does it happen with a particular project, or all projects? If the latter, it is almost certainly an iOS 10 issue. It’s possible the zip framework we use needs updating for iOS 10. Do you have similar problems exporting to Word format (that also uses the zip frameworks). I haven’t tested Scrivener for iOS on iOS 10 yet as the focus has been getting it ready for release. I’ll be testing on iOS 10 in the coming weeks so have made a note to test this.

If the crash only happens with a particular project, please zip up the project and send it to ios.support AT literatureandlatte.com. (You’ll need to sync the project via Dropbox and zip from your Mac, of course!)


It happens with all projects, even empty dummy projects, on my iPad. Compiling to Word document works fine, however. I installed Scrivener on an iPhone 5 with the same iOS 10 Beta 2 and can export as Zip there without problems, though. Rebooting the iPad did not help. Very strange.

Since the export did not crash on my iPhone, I went ahead and tried Airdrop’ing the project to the iPad and could receive it, but Scrivener was missing in the Airdrop Open With… dialog on the receiving side. Apps listed were: Ulysses, PDF Expert, Coda, Mindnode. Can somebody reproduce this issue or is it just me with my wired iPad?

If I understand this correctly and the issues are resolved, one could exchange Scrivener projects simply using Zip archives, e.g. through email, iCloud Drive, Airdrop?

Hmm, very strange that it’s only happening on one device, and that .docx works fine when that uses the same zip routines. Well, I have it on my notes to test with iOS 10 in a couple of weeks, so I’ll see what I find.

This feature is really for sending projects to other people or for making backups, though. Scrivener can’t open .zip files, so you couldn’t share projects inside Scrivener this way.

Thanks and all the best,

This just to confirm that I have the same bug happening on an iPad Air2 running iOS 10 public beta 2. The app crashes systematically as soon as I attempt to export an archive (Zip). No big deal as Scrivener can’t import directly these backups anyway. But well that’s still a bug. Curiously on iPhone (6s here) running iOS 10 public beta 2 as well the issue doesn’t occur, never.

As to simply exporting as PDF or else, everything works almost as expected. I just noticed yesterday that exporting just one document in a project to Word for iOS exported the whole draft (all documents).

edit: I’m aware that iOS 10 beta isn’t supported … as far as I know developers aren’t allowed to update their apps for betas. So I guess beta testers will have to live with a few glitches until iOS 10 is released in September. Scrivener is not the only app that doesn’t play well with the beta.

Yes, I really wouldn’t recommend using it on iOS 10 yet - you do so at your own risk.

I’ll be thoroughly testing it on iOS 10 myself later, and do appreciate reports of issues, though, to help me direct my attention to problem areas. In my experience it is rarely worth spending time fixing up an app to be compatible with early OS betas, because Apple fixes so much in the first months of the betas. (For instance, Scrivener for macOS was crashing every time the Compile panel was opened in Sierra seed 1, a bug fixed in Sierra seed 2.) I therefore tend to wait until the month before the OS release for thorough testing and fixes.

ok, thanks for the feedback :wink:

The problem is still there for me in the iOS 10 Golden Master on my iPad.

It’s caused by a very silly change Apple has made to the app pucker. I’ve found an (ugly) workaround and will release an update with the fix soon.

I have nothing substantive to add here, I just like saying “app pucker.” :slight_smile:

Dammit, writing late. :slight_smile:

Also, to clarify on my “soon”, which was a bit vague: I’m going to wait a few days to see if we get any more significant bug reports with iOS 10 so that we can roll them into a single update. I’ve been testing on iOS 10, and other users have been trying it out, and so far, this is the only bug I know about, so fingers crossed…

I’m leaving Saturday on a cruise across the North Atlantic and since I’ll be depending on zipped backups while I’m out of cell tower range :slight_smile: I’m hoping this happens soon. . . . Please? Pretty please?

A couple of workarounds are discussed in this thread:


It seems this bug doesn’t happen on smaller screens, even if the smallness is caused by using the iPad split screen function. So if you can split your iPad screen, or if you have and can stand working on an iPhone or iPod until the fix comes out, you’re good.

I’m just jumping into this thread to report that splitting the screen doesn’t work on the larger iPad Pro screen.

I wish I had known about this before updating to iOS10 since I no longer have easy access to a Mac.

Is there an estimate for a date when Scrivener iOS will update to work with iOS10?


You might have already done this, and/or it may not be applicable to the 12.9" iPP at any rate, but I found that for the workaround to work on the iPad Air 2, Scrivener had to be sized at 50% or less. If iOScriv was 50/50 with another app, it worked. If iOScriv was on the smaller screen from the right, it worked. If iOScriv was on the larger screen on the left, no joy.

I can confirm that I also get this bug on ipad air ios 10, but not iPhone 6 ios 10.
As an obvious work around I just male sure dropbox is synced and then export as zip from the phone.

Just stumbled across this thread and decided to test it: Scriv/iOS crashes on my iPad Mini 4 when exporting via “Send a Copy” right after counting up through all the files in the “create an archive” alert. iOS 10.0.2.

Crashes exactly the same on iPad Pro 12.9", iOS 10.0.2.

Crashes exactly the same on iPad Pro 9.7", iOS 10.0.2.

But works okay on iPhone 7 Plus on iOS 10.0.2.

All tested using exactly the same source project, freshly synced via dropbox.

Apologies, I meant to release a bug fix to this two weeks ago, but got bogged down in 3.0 code and updating the Dropbox code for iOS (since Dropbox has switched over to a new API) - I will be sure to put it out this week. It’s a new annoying bug introduced by Apple in iOS 10, but it only affects iPads. Sorry for the delay in getting a fix out.

Update: apologies again. I got caught up in some big code changes this week and did not get chance to release the update earlier in the week, and as I’m on holiday next week from tomorrow onwards, I didn’t want to release the update at the end of the week in case anything went wrong with it that needed my attention while I was away. So I will release it the week after next. Again, my sincere apologies for the inconvenience here!

I have the same problem with all my iPads. On the iPhone works the “zip” export.

Kind regards