Floating keyboard covers text

Floating keyboard still covers a large portion of the text on iPad.

Hmm. I’m back on my Magic Keyboard again, which is truly worth it, and types like new after a year with a very fine touch, but I wanted to see for times with the screen keyboard also, so tried this.

I found:

  • If I start typing at a visible point on screen above the keyboard, the fresh Scrivener works as we wish it would – keeps the line you’re typing moving up so it’s entirely visible with spacing below it, shifting up when text wraps (or you hit return).

  • However, if you place an insertion point, and then manually pull the screen so that’s not visible because under the keyboard, then typing will not auto scroll so that it becomes visible.

    This is the only case I’m seeing where text would be hidden. I’d count it as very nice if Scrivener would auto-scroll to show text then, and if there’s a catch-bugs re-release of the new Scrivener, very good if this could be added to the feature.

  • Workaround: I might never have caught the issue here, because I generally use the reduced keyboard on the iPad when it’s on its own and I need to.

    What’s that? I think it’s actually the keyboard from the iPhone, and it has two advantages. It’s quite small (but not too small), and moveable, so it never needs to hide anything on the screen. And, it does ‘trace typing’, which means you have something much than nicer tapping on small keys.

    You just trace through the letters of each word you want, and in the usual way, the iPads intelligence works ou the word you want even with inaccuracies, almost always correctly. This is very fast and handy, much better in fact than typing on the glass; at least I find it so.

    You get that small keyboard by pinching the large one as if to close it, iPad fashion, or just as if to make it smaller. If you want the large on back, you in-pinch the small one. Easy as that…

  • Quick fix: if you are on the big keyboard, and manage to scroll the entry point out of sight, just click the T icon on upper left of edit screen, which will put you in Typewriter mode, where as explained above, tthe entry point will be vertically centered in the available window. Then click T again, if you’d like to go back to non-Typewriter mode…

Just to clarify, when this happens, the keyboard is already set to the floating style before you enter editing on a document in Scrivener, correct? The only way I’ve seen something like this is by starting out with the full keyboard and then shrinking it while editing a document, and if that happens, simply moving the keyboard will cause the editor to redraw and the text to flow properly to the bottom. In your case, I am assuming that the keyboard is already floating when you tap into the document to start editing and that moving it doesn’t change the cutoff. Since we haven’t been able to reproduce that though or figure out why the editor is receiving the wrong keyboard height, I want to make sure I’m not misunderstanding the symptoms.

This is a bug that we’d hoped was fixed in 1.2.2 and which I’m not able to reproduce any longer (whereas I could trigger it in the previous version). If I place the insertion point and scroll so it is hidden behind the keyboard, as soon as I begin typing the editor scrolls so the line I’m writing on is visible just above the keyboard. I’m currently working on iPadOS 14.6, so it could be a matter of the system version, if you’re on iPadOS 15.5. Does hiding or showing the extended keyboard row make any difference to this behaviour?

Interesting to try…

  • Yes, I’m on 15.5, which seems impressively stable, if not quite flawless, in the fashion of any of today’s software. But there may be some advantage in sticking to an older version that some number are still going to have, particularly in these parts, for sure.

  • I tried what you said, by setting insertion, scrolling it out of view, then pinching to get the smaller keyboard, then un-pinching to return to the large.

What happened then is that it almost worked. The scrolling jumped to show the line just above the insertion point, on the first key press. So you still couldn’t see it but were very near.

  • Once again, Typewrirter mode would set things ariight. But then no keyboard switch and back would be needed, so this probably is still the best workaround.

  • Good catch, in that possibly @drking is already using the small keyboard, if that is what ‘floating’ means. If so, that’s a possibly different test to make.

  • SoI tried the same moves with the small keyboard, and in fact it works as desired: scroll insertion off screen, type, and the scroll position jumps so that line you are typing on shows properly at the bottom of the screen.

    Or more nicely, I felt, at vertical center, also proper, if you are using Typewriter mode with the T button.

Just to be complete, I did see one glitch, for a moment. The first time I switched to the small screen keyboard, the screen area the large one had covered in the editor remained blank, didn’t fill in. It did refresh properly as soon as I moved the small keypad a small amount.

  • I think it would do the same if one just started typing, and I never saw this happen again on a number of tries. It could have been anything, iPadOS having a moment as it occasionally does when my Wifi drops out, for example. I wouldn’t concern unless it were noticeable enough to get reported, or can be replicated by a very diligent and patient tester.

  • And in fact, when I tried to Send/save this reply, I found the Wifi had indeed dropped, so that is probably the whole explanation. Unfortunately it’s not something I have the access to fix, and the speed is great while it works…life goes on, in our big software city, doesn’t it…!

I don’t use the regular keyboard hardly at all. I use the floating keyboard for everything. Very rarely do I switch to the full-size keyboard.

The keyboard is already set for floating when I go inside Scrivener.

Wherever I move the floating keyboard, the text is obliterated around the keyboard as if there is a large white space behind the keyboard, except that the area is much larger than the keyboard, I would say about 3 times the size of the floating keyboard.

Yes, by floating, I mean the small keyboard. :+1:

Also, I will mention that once in a great while I can go inside Scrivener and it works as intended (where there isn’t the white space behind the keyboard). However this is very rare it only works for a short time.

I’m not sure if this matters, but I don’t use Wi-Fi, I am using cellular for my iPad.

Yes, that’s quite a different case, and I can’t get it to happen at al, here.

I would leave this situation to Jennifer, MM, for her always responsible guiding you through, but it suggests back to something possibly corrupted in Scrivener settings or installation, if not the iPad itself.

Careful is best, and with full backups of the iPad, besides your Scrivener projects, assured before venturing.

I’m presuming you don’t see this problem on other text editors, like Mail for instance, and that you did power down and start up again the iPad, per the Apple link above…

1 Like

Before the newer version came out, this was occurring in the prior version as well. I even deleted the app and reinstalled it to see if that would help but still the same problem. Someone else mentions it in the app reviews having the same problem I am. So I know there’s others having the problem. I was hoping with this new version, that the problem would be fixed because it’s very annoying. :weary:

1 Like

You know, really this (along with the other in play this morning) is a pretty puzzling problem. It should either show, or not show.

One further question, do you see this the same on all Scrivener projects, over the ones you’ve had for a time— and on a freshly begun one after the upgrade, when you type text in it enough to check a page?

That’s two questions; they tend to multiply :slight_smile:

Thanks for your reply. Yes, to both questions. :+1: It occurred in prior version with all projects and also in the new version with all projects.