Font and Background colors - Cursor color

I like to work with a black background and green font.

However when I do this I cannot see the cursor… is there a way to set the cursor color?

Also, when I’m in a Scrivener project it seems that I have to set the background and text color for each individual document under the Drafts category. Is there some way to set this globally?

Thanks for any tips!

To change colour of cursor:

Scrivener > Preferences > Appearance, then in the Customizable Colors section, select ‘Editor’ in the left column and ‘Insertion Point’ in the right. Change the colour by clicking on the swatch.

You can change Text Background from the same list (i.e. Editor > Text Background in Customizable Colors). These changes will be reflected immediately in all documents. You can elect to have different Colour settings for the editor and for Composition Mode by checking the tick box in the top line of the section…

To change the default text colour, choose the Formatting tab in Preferences, then click and hold the left hand of the two coloured rectangles in the toolbar below ‘Main Text Style’ (i.e. you want the one to the left of the rectangle marked ‘abc’). This will bring up a swatch. Choose your colour. The dummy text will change to reflect your choice.

The new text colour will be reflected in all new documents. To change ones you’ve already created, highlight them in the binder and select Documents > Convert > Formatting to Default Text Style. You’ll be given a choice about how far the automatic conversion will extend – if you only want to change the text colour, then tick Convert Font Only.

The above is a lot more complicated to describe than it is to do, and it’s a one-off process…