Font Change Causes Crash

On IPad, if I select text and try to change the font, the app immediately crashes. I’ve reproduced this one a lot. :slight_smile:

Is the font one that you have imported, or just a standard system font?

Standard font.

Could you please provide exact reproduction details (including device etc), along with the font used, and, if it only happens in a single project, send us a copy of the project? Changing fonts works fine for me, and we’ve had no other reports of this, so there must be something particular going on either in your project or on your system. I therefore need as much information as you can provide in order to track it down.

Thanks and all the best,

Okay. I have three different projects that I created in Scrivener for Mac and brought over to Ipad. One I actually created in Ipad and copy/pasted the data from another ipad app, but the others I used airdrop to get over and then synched up to dropbox.

The one I created in ipad is in the Palatino font and the other three projects are Helvetica. All four of them crash the second I go into formatting and click on font. I tried attaching one of them from dropbox to this, but it’s saying invalid file extension?

Oh, these are all crashing on my Ipad Pro.

Are there any font utilities/managers, alternate keyboards or system/app fonts installed on the device (not necessarily being used, but just installed)?

Do you mean attaching something to a post here? Try zipping the file you’re trying to attach. Not every type of file can be attached by itself.

Speaking of attachments, if you could send in your crash report(s) that might help. You can PM me for privacy, or send them to our main support address and flag this thread URL so that whoever gets it can direct it to me.

Okay, thanks. I think I successfully private messaged you a crash report.

BTW, I tried deinstalling/reinstalling on my ipad, and that didn’t solve the problem.

Oops, in answer to the question I did see… Yes, I do have some alternate keyboards and a font utility installed.

I tried taking them out and rebooted my ipad. Still have the problem.

When the font utility is removed, does that also remove any custom fonts that may have been installed at the system level? My thinking here is that since the crash occurs immediately after tapping on a button which would require Scrivener to generate many dozens of font previews, there may be some font that it can’t process correctly for some reason.

Thanks for the crash log by the way. Unfortunately it’s not terribly informative from what I can see. The method names that would indicate what was going on at the time of the crash were lost. There was a lot of networking going on at the system level, but it’s an iDevice, that probably doesn’t say much. :slight_smile:

That fixed it! I took out the fonts at the system level and the problem was solved. Now I can get into the fonts. Thank you!

Hello! I recently started using Scrivener on my iPad and am facing the same issue. I can’t get into the list of fonts. Even before that, it crashes. Can you please tell me how you solved the issue? Thank you!

No, you’re probably not. This thread was created four years ago. Start a fresh thread where you describe your problem with as much details as possible.

And just in case it is the same problem, they noted what they did, in the post above: