Font issue switching between platforms

I use Scrivener 3 on Windows and mac, and sometimes iOS. My projects are stored in my Dropbox folder and I always make sure to sync correctly. What ens up happening a lot is that the font of certain documents within my projects after swapping from one platform to another are completely broken. When this happens, I need to select the text, copy it in another program and paste it back in a new Scrivener page to fix it, which makes me lose all formatting, so I have to read the entire text and put italics etc back in. I can not just select the text, swap to a different font and back, that does not fix anything. This problem makes me scared to swap between computers now, so I just don’t do it anymore, which makes me miss out on precious writing time or forces me to use Google docs and hope nothing gets lost copy/pasting between Scrivener and Google docs.

Has anyone else experienced this issue and found a fix? Pictures of what happens to Cambria regular when this issue occurs: https://imgur.com/a/FvVvVKw

Cambria doesn’t come with the default fonts on Mac, so your computer will be swapping the font for something similar to display your text. For the most seamless experience going between platforms, you’ll either want to install the font you want to use on all devices or use a font like Georgia or Times New Roman that comes by default on all devices.

2 Likes

I use Cambria on Mac as well, and it goes alright for some documents in a project, but not others, which is why it’s so strange. And it doesn’t only happen when I use Cambria, it happens with other fonts too.

Are you experiencing this in multiple projects or one specific project?

If it’s a specific project, you can try resetting the project’s displays (Mac instructions) or dragging and dropping the contents of the project into a new project and see if the problem follows.

If it is the top part of what there is to see in your link that is wrong, that font is outlined.
image

image

I recall @AmberV mentioned this to happen from time to time when syncing across different platforms.

You can cut your text then use Edit / Paste and Match Style to input it back right away. That would clear the formatting. No need for a back and forth to some other app.
But if your issue is only that some text has its font outlined, select all of your body text then click the menu item or shortcut (as per my screenshot) twice. That will preserve all other formatting.
(I think I customized that shortcut, use the menu once to know what it is on your machine.)

3 Likes

This is indeed what was going on, I had no idea about ‘Outline’ because I only use the font formatting at the top of the editor. I opened all of my most recent projects on m ac after working exclusively on Windows for a year to avoid font issues. Some documents were indeed outlined, but others were all bold or all italic and bold. Getting rid of it meant losing all the italics formatting that should have been in there :frowning:

Still not perfect, but now I have to hope it stays with the easy to fix outline instead of losing all italicized words after switching platforms.

I am not knowledgeable as far as cross-platform issues go.
But an idea : what if you snapshot your documents first ?
Perhaps these, the snapshots, will remain intact, offering you the option to rollback?
Not ideal, but better than losing all of your formatting.

Another idea : style everything until the final compile? (I’m not sure that’ll prevent anything, but perhaps it is worth the try.)

Reading up on styles now, I hadn’t used them yet, but it might help out here. So I’d have to make a style with Cambria regular, one where it’s italics and one bold, and use those styles instead of selecting words and hitting ctrl+i?

No. That would be uselessly complicated.
Here is what I have in mind :
(Of course, make sure you backup your project first.)

Go to a paragraph that is “No Style”.
In a little chunk, have one word “normal” (no bold, no italics, no nothing), one bold, one italics and one bold+italics.
image
[EDIT] Save that chunk (copy/paste) to a new document for later. Put it at the very top of your binder.

Select those words, and create a style :
image

Apply that style to whatever is No Style.

With any luck, that will lock the cross-platform whatever it does out of your paragraphs…

Do it for just one chapter, then ping-pong your project from Mac to Windows to Mac to Windows a couple of times.
(Might as well save-as your project to a test duplicate – with proper naming. No need to mess up your real project.)
See if it changes anything. (?)
If it doesn’t and you still get your fonts messed up, then try and set the chunk I had you save to a new document straight, redefine your style from it and see if that fixes things.
And if that fails too, try changing your messed up paragraphs to another style (that is paragraph formatting only) and back.

→ But if your issue is only that fonts somehow become outlined (outlined and that’s it), no need for any of this.
All you have to do is select all of your text, click the menu “outline” once to make all of it outlined, and once more to remove the outlined attribute.
If it is all of your text that’s outlined already, clicking the menu “outline” once will suffice.

Else, if snapshots are not affected, taking a snapshot of your documents before you transition from a platform to another may well be far more convenient then trying to prevent or fix the issue using styles.

Logical order by which you should consider potential fixes :

  • Format / Font / Outline
  • Snapshots
  • Styles