Hi support,

I have problems with quite a number of postscript fonts in pull down menus of the preference boxes. If an entire font family comes in a single suitcase I am unable to choose the right font within a family in pull down menus. Most of these fonts are of excellent quality, the product of skilled font designers. Example: FontShop - Thesis theSans - by de Groot. A font family divided into 8 suitcases, each containing 6 font cuts. Scrivener allwith chooses the font found on top within a suitcase. TheSans is an excellent font, designed with special care for screen readability. Therefore I want to use it. What do I have to do, to be able to choose every professionally designed postscript font within Scriveners prefereces?


Christian Tobler in Switzerland


I’m not 100% sure what you mean. Could you possibly post a screenshot showing the problem?


I’m not quite sure what you mean either.

What I do know from my own experience is that the Apple TextEngine sometimes gets confused when a PostScript font family – wether in a suitcase or not – contains more than just regular, italic, bold, and bold italic. Confused meaning: When you hit cmd-i you get the italic font but when you hit it again the font is not set back to regular but to semi-bold or something. Maybe this causes some other trouble?

Scrivener uses the Apple TextEngine. So does TextEdit – so the best way to pinpoint the trouble maker would be to try to set your fonts in the TextEdit preferences too and see if it does work or not.

That’s one thing. The other – what do you mean with “unable to choose the right font within a family in pull down menus”? What pull down menus?

For example, in Scrivener’s Preferences/Text Editing right below Default Main Text Attributes there is a pull down menu named Styles. Is that the one you refer to?

Indeed this one does only contain Default, Italics, Bold and a few more (and maybe some customized styles). It is, again, the Apple TextEngine standard style menu (which is, without doubt, not very useful).

If you want to choose a specific font from a font family you have to click Set Font right beside the font name below the text example box. This opens the standard font palette, which you can reach via cmd-t in lots of programs working with text.

Is this of any help to you?

Hi Keith, hi Suavito,

thank you for your fast replies. My setup: OSX 10.4.11 on an titanium Powerbook. I am using the tool Suitcase X1 version 11.0.2 to handle my fonts, turning the necessary fonts on when I need them. The screenshot suitcase.jpg shows you the font I mentioned activated within suitcase. I can only activate all font cuts within a so called suitcase (not the software) of postscript fonts together.

If I am in Sciriveners preferences boxes and I want to activate a specific font cut of the mentioned font, whoes fot cuts are stored together in a single so called suitcase, the necessary sub menu in the pull down menu does not apear. Scrivener does not allow me to specify the desired font cut. Look at the screenshots textediting.jpg and fonts+colors.jpg.

I would never use the checkboxes Italic and bold. I want to use the proper font cut instead of electronically faked fonts.

The screenshot textedit.jpg (next message) shows you that the same font in TextEdit causes no problems. An other screenshot named texteditpref.jpg (next message) show again, that there is absolutely no problem with this font.

Enclosed is also an screenshot called xpress.jpg (next message) showing the necessary submenu but in Scrivener missing sub menu in the pull down menu. I made it in XPress version 6.1. As you can see there the same font functions without problems as well.

This problem is not caused by this specific font. In my font collection there is a number of professionally made postscript font of different manufaturers that don’t function in Scrivener.

As I can only attach 3 files, screenshot 4, 5 and 6 are attached to an other message.

Regards - Christian

Here the missing screenshots 4, 5 and 6.

Perhaps something is being lost in translation, here, because it looks to me like all of the ‘cuts’ within each font are present in the font selection menu. In the case of TheSans, they’re right above the selected item…?

Okay, the font list in the pop-up menu only shows font families, and not the typeface (it would be odd for it to show “Courier > Italic” and so on rather than just Courier) which is why you aren’t seeing them, as you have them arranged as typeface variations of the font family. The next update (which won’t be available for quite some time, mind) changes the Preferences so that you use the regular font panel to select fonts rather than the pop-up menu, so this shouldn’t be an issue then (although the pop-up does still occur in a couple of places), but unfortunately there isn’t much you can do about this at the moment. Sorry.

All the best,