Fonts and Line Heights

If someone’s already asked this, my apologies. I couldn’t find anything related. Here’s my problem:

I have a document with several fonts, in several different languages, placed side by side on the same line. Unfortunately the line height seems to change depending on what font I’m using. Is there a way to keep the line height the same, regardless of the font used?

It may suffice to apply a line height large enough for all the fonts.

Sorry, I don’t really understand what you mean. Under the “set the line spacing” button when you select “other” and it takes you to a panel, you are left with 4 options:

-line height multiple
-line height (three choices/options: exactly, at lest, at most)
-paragraph spacing

I’m really confused which option I should fiddle with, if this is in fact the right place to fiddle things with. I’d like it so that, regardless of the font or the language, every line is spaced evenly between each other. How do I do this?

Make the line height larger.

What you’re running into here is dynamic line sizing keyed to the height of a given typeface (font). There are not many ways to deal with that satisfactorily by just changing the point size (that is, setting everything to 14pt), because depending on how the typeface has been designed, it might be calling for different spacing in the lines.

You’re on the right track, using the “set line spacing” options.

Before you start making changes, select all the text in the window. As you make changes, the view will update automatically, so you can see the results live.

What you’ll probably want to do is set Line Height to Exactly, and then enter the point value you want. Single spaced text would have the line height equal to the point size. If your overall point size is 14, and you wanted to single-space, set the point value to 14. If you want to double-space the lines, you’d set your point value to 28 points (14 + 14). If you want it to be 1.5 space instead, you’d set the point value to 21 (14 + 7).

What this should do is force Scrivener to display the line height at a hard value, without attempting to dynamically change line spacing in response to different typefaces being used. The result should be that all the lines have the same amount of space between them — no large gaps.

I tried this thanks. Setting things “exactly” works but only if I set it to a really large number which isn’t aesthetically pleasing.

Well heck. Best guess is there’s something in one of those fonts that’s calling for much more leading than usual between lines, and it’s throwing everything off.