Fonts Colour in Dark Mode

Hello, I am not sure whether this should be reported as a ‘bug’ or the feature is just missing (by design?), however once I switch to ‘dark mode’ on my iPad it seems not possible to change the colour of the default font. I want to make it fully white, but regardless of the colour I choose it does not change. Anything I am missing? And would it be possible to use / customise different styles for the background, as in the mac version?

iOS dark mode doesn’t display colors. All colors are washed out to gray. If you return to light mode, your text color should be displayed.

If you go to the iOS settings app, scroll down the app list and find Scrivener, you’ll find a few options for background color, but you can’t set background to an arbitrary color as in the Mac version.

Hope this helps!

Might not be what you’re looking for, but–

With Scrivener in light mode, I use the system option (toggle) at Settings app > Accessibility > Display & Text Size > Smart Invert. (If it’s something you’d use often, you can create a Control Center shortcut.)

That’ll change the Scrivener default text color to vivid white on a black background. Other chosen text colors will be visible, as well.

I totally agree that needs more colour options in the dark mode of ios/ipados. the dark made makes me sleepy (blue light I’m figuring), and the light mode is too bright. but it’s a small thing I guess.

Aha! This seems to be true, and resolves the bug I reported about Revision colors just showing as grey on the iPad.

I agree with later comments – dark mode should show colors.

One more tricky thing (that could be resolved on an update) is that Scrivener Dark Mode is separate from iPadOS dark mode – you have to set it on its own, in the main iPad Settings | Scrivener | Appearance.

Very good to see this unified, in a fresh release…