Footnote export/compile

I have been using Scrivener for a long time now, and I like it. However, I need to edit some stuff with reference notes:

  1. in the main text, is there a way to avoid the reference mark for footnote/endnote to be placed after punctuation marks? It seems that by default Scrivener places it there (the way it selects a word when a footnote/endnote is inserted). This is not important while working in Scrivener — formatting is not an issue. But once the draft is exported, those marks are placed after punctuation marks, which is not ok with all languages. If I work in French for instance, it means that each single reference number must be relocated at its correct place (before a comma, a closing quote mark, etc.).

  2. notes are exported, but they are not recognized as such. I tried Pages, OpenOffice, Word, Nisus: if I need to add or suppress notes (as it happens when the formatted text gets some adjustments between main text and notes), that starts as a new list of notes.

  3. in the notes, numbers come without punctuation before the text of the note.

I guess that I missed something, it would be too much editing otherwise.

  1. The footnote will come at the end of the selected text, if it’s an Inspector footnote, or at the beginning of the inline footnote. If you’re inserting a footnote at the end of the sentence, insert it before typing the final punctuation or select the last word manually so you can avoid selecting the punctuation with it.

  2. What format are you using to export? Not all formats recognize “real” footnotes, but RTF should and that’s compatible with Nisus, Word, etc. (Not Pages; Pages is kind of its own obnoxoius issue and you’ll really need to go Scrivener > Open Office > Pages if you require Pages and good footnotes.) Mine come up properly as footnotes in Nisus Pro.

  3. I’m not clear on what you mean for this, but perhaps it’s related to the footnotes being faked instead of being recognized as footnotes, re: question 2?

If you need this, you should select the text you want it be applied to before clicking on the add note button. If no text is selected, the note will get added to an automatically-generated range including the punctuation; but if you select text, the note only gets added to the selected range.

Only RTF export (and .doc export provided the Preferences are set to use the RTF-based .doc exporter, which they are by default) support “true” footnotes. Other formats just export them as flattened text. Pages doesn’t properly support the RTF format, so the only way of getting true footnotes into Pages is to export as RTF and then use an intermediate program - e.g. Word or OpenOffice (not Nisus, which uses RTF-based .doc the same as Scrivener) - to re-save the file as .doc or .docx. Otherwise, save as RTF - Word, Nisus and OpenOffice all fully support the RTF format (although OpenOffice won’t read RTF comments - it will read footnotes though) and work well with Scrivener-created files.

I’m not quite sure what you mean by this one, sorry. Oh, do you just mean that the footnotes come out as, e.g., “1 Blah blah” rather than “1. Blah blah”? If so, that’s fairly standard - that’s how footnotes are done by default in Word and Nisus for instance. If you need different formatting, you should adjust it in your chosen word processor.

Hope that helps!

All the best,

With due respect Keith, this is not 100% correct if you are using Nisus Writer Pro 1.4 or above. That gives you the option of exporting to binary .doc, which preserves the footnotes, which then appear properly as footnotes in Pages. The same may be true of the other elements such as tables, images or what have you that Pages won’t import from a Scrivener .rtf.

Still an intermediary step, but those who use NWP and Pages do not need to use OpenOffice or one of its clones to achieve this.



I didn’t know that, although I did know Nisus had started using the OpenOffice exporters, so I must have missed the option. That’s great news though - I love Nisus, so it’s good to know I can recommend it for converting files too. Thanks for the info.
All the best,

Thanks all for the prompt answers.

  1. Indeed, if I only select only one character before adding a note, the note is properly placed upon compiling/exporting.

  2. RTF works fine. I should have read carefully the manual.

  3. Yes, the issue is “1. Blah blah” vs “1 Blah blah”. It would be nice to have this format available for compiling/exporting (as it seems, a word processor will not override it and change everything all at once).

Aside from this finicky preference of mine, Scrivener works great!

Thanks again,

Just found out that OpenOffice can do it. Not sure for NisusPro.

NWP will do it. Switch to modifying styles, select Footnote from the Note Styles, and then remove the superscript from the footnote numeral and add a period and space to the “default note text” and it should do what you want.