Footnote numbering not restarting on new pages


I’m writing a novel that makes use of footnotes and I would like to have the footnote counter reset on each page. I’ve created a compile format that I like, I’ve ticked the “Footnote numbering resets after page breaks” check box in the “Footnotes & Comments” tab, but it just doesn’t seem to take that into account.

When I compile my document, I get a continuous run of footnote numberings. I tried including some screenshots to illustrate my problem, but my account is not trustworthy enough yet I guess.

I’m not sure if this is a bug or I’m just missing something, but googling has yielded no further useful information on the topic.

Help would be appreciated.

Page breaks at compile are between sections. (If set so.)
Or, in other words: between documents/files.

New pages, in the normal flow of things, are not coming from them.
So the condition isn’t met in your case.

What format are you compiling to?

Aha! I’ve spotted the culprit!

I guess I should have also mentioned that I was trying to compile to PDF. And that particular option doesn’t show up when trying to compile to PDF…

But magically appears when compiling to RTF

(I have image powers now!)

Is there no way of getting it to compile that way directly to PDF? Do I need to compile to RTF and then export that as PDF?

From my limited experience I’d think so.
Compile to RTF, use LibreOffice to convert it as-is to PDF. – An extra 5 minutes well spent.
(It should technically work fine. But as I said, I never tried this specifically.)

Yeah, it’s not a big deal. Just find it a bit odd that that would be difficult to achieve when compiling directly to pdf. Well, thanks for the help everyone!