Footnote Numbers Not Superscripted in .docx in 3.2.1

In compililng to .docx format, the new built-in converter has a glitch. In documents with footnotes, the footnote number in the complied document is not superscripted, either in text or in the actual footnote.

Superscript is preserved in the .doc and the .rtf compiler. That provides a workaround, but I wonder what I’m missing when compiling to either of those formats, and then using Word to covert to .docx.

Still on Catalina (10.15.7).

Any help or suggestions appreciated.

The reason for the missing superscripted footnote number is that either the footnotes nor the footnote anchors have any paragraph formats attached to them in the compiled docx. Or sometimes (this changes weirdly when clicking around in a document) the Standard paragraph format.

They used to automatically use the standard Footnote Paragraph and Footnote Anchor formats which include superscripted footnote numbers.

The new compiler needs to somehow activate the Footnote Paragraph and Footnote Anchor formats once again. Or even better the compiler allows to attach a customizable paragraph format to footnotes and their anchors like to all other paragraphs.

I appreciate the diagnosis. Do you have any suggestion for a cure? Unfortunately, in my line of academic work footnotes are nasty necessaries. Thanks.

You could manually add the Footnote paragraph format to every footnote and the Footnote Anchor format to every footnote anchor.

But even if my academics days (sadly) are over I am still able to remember very well that in that field one normally has significantly more footnotes than just, say, three. So I would not dare to call this a cure.

Seems to me the obvious workaround is to compile to .doc/.rtf format. If you are writing academic papers, you are not going to lose anything by doing so.*


  • In fact, when I compile to Word, I always end up selecting all and copy/pasting the whole word doc body into a fresh new (docx) document anyway, because the Scrivener-generated ones for some reason do not invoke my Normal template with all my preferred tweaks. So, for me, doing as suggested above would not even incur an extra step.

Wouldn’t Insert/Object/Text From File be the recommended way to import into a Word document? That way—at least theoretically, we’re talking MS Word here!—only the paragraph names are of any importance. Meaning: Scrivener compiles a document with Heading 1, Heading 2, Standard, Blockquote &c., but the template of the document opened in Word overwrites each value of those paragraphs.

Thank you, thank you, thank you for this!

I have been trying to figure out what I was doing wrong for far too long. As one who is also writing an academic paper with hundreds of footnotes, the post-compile formatting is sadly not an option, but thankfully compile>.com>.docx works well.

Interesting, I’ll have to try this. Not sure in what way to expect the results to differ, but am all over curious.


I’ve fixed this bug for 3.2.2, which will be out before the end of next week. (The new converter originally started life in our iOS version, and it turns out that there’s a difference between the “superscript” attribute on iOS and macOS which caused the problem.)

Thanks and all the best,

Thanks for the quick response and fix. Looking forward to the next version.

And thanks for such a superior piece of software, and for your responsiveness.


To whom it may concern–

I’ve been computing since 1983 or 1984. And I don’t remember ever complaining like this. But I must say, it is absolutely RIDICULOUS and ASTONISHING that the version before 3.2.2 (3.2.1, I imagine) was released with this superscript problem or issue. It seems to me that this would be an important and essential thing to quality check before releasing a new version(?). Didn’t somebody think to compile an example dissertation or research paper with citations and numbered footnotes? (as in Chicago style dissertations). Is this too much to expect? Imagine how many of us were greatly inconvenienced when the “new improved version” of Scrivener came out and we were googling our asses off trying to figure out why our citations/superscript were suddenly messed up. For no apparent reason. Incredible.

–Yours truly, Rezeski

Shocking as it may seem, we are human, and no matter how much quality testing we do - which is A LOT - bugs get through. The new .docx exporter was written completely from scratch. Writing a .docx exporter is an ENORMOUS job that takes months, and so complicated that, no matter how assiduous you are in coding or testing, small bugs are bound to make it through - a truism of all development. This is exactly why I left the old exporter available - so that if users experienced any issues with the new exporter, they could switch to the old exporter via the Preferences and so export with exactly the same results as Scrivener pre-3.2.

There are many, many Compile options, and it is almost impossible to test every single variation of them. We do our damnedest, but occasionally things slip through. When they do, we fix them - I don’t think I’ve ever before had a user complain so vociferously about a bug after it was fixed, which this one was, in 3.2.2.

Anyway, a happy holidays to you too.

Dear Keith,

Thank you for your so excellent work.
I had an issue about footnotes anchor superscript position. (Scrivener 3.2.2. / MacOs 10.14.16)
While exporting to PDF, the size and position of the footnotes anchor relies on the style of the first paragraph in which such a footnote anchor appears. ➭ My issue appeared because I put such an anchor in the first title.

I spent hours searching around where I could influence the font and size of these anchors (which appeared so big in my paper). The information I give you here may be inserted somewhere in the Manuel.
I’m still unable to manage the default layout of the footnotes; I couldn’t find where I could do it.
May a dedicated style for the footnotes and another one for their anchors be advisable?

Thanks anew for your amazing work.