Footnote separator line settings

I am not sure why, but my footnote separator line is now ]to the left of the text margin. I cannot seem to find the setting that controls how far to the left it is?

[attachment=0]Screen Shot 2020-10-02 at 8.05.59 AM.png[/attachment]

Was it aligned with the margin previously? What, if any, changes have you made since then? Have you changed the indents for the text, for instance? Or made any change to the margins? Which compile format are you using? Sorry for all the questions!

No, changes to the margins that I can think of, but possibly. I just can’t find a setting that controls the footer separator line. When I have the footer line set to be the width of the text, the whole thing is offset, but appears to be the width of the text.

I found the problem. I had added printer’s marks to check the look of the page size. When I unchecked that, the footer separator line is aligned correctly with the text margin. Is this a bug or expected behavior?

Are you compiling to print? There is an option in the Compile format on Footnotes & Comments for Separator Style. But looking in the manual (p.663) I can’t see any that should do what you are seeing. Are you using the facing pages option to make the left and right margins different?

I was typing this when I saw your next message. The printer’s marks shouldn’t do that. Perhaps changing the Separator Style to something else and then back might reset things if it is a bug.

Yes, I’ve just created the index with TExtract and almost have finished the formatting for the index which I’ve tacked onto the end. Hope to get this done and final book cover, ISDNs, and copyright submission by tomorrow.

Just to let you know that this bug has been fixed for the next update, which will be out around the same time as Big Sur. Thanks for bringing it to my attention.