Footnotes disappear

I am an academic writer, and I love Scrivener. It allows me to work on a full manuscript, and it enables me to keep notes and research results together with the manuscript in a way no other software I’ve seen does.

However, as an academic writer, the footnote option is essential for me. I just ran into something that startled me a bit. Perhaps I’m doing something wrong–if so, please tell me what it is so I don’t do it again.

There were a couple of things that were formatted oddly in Scrivener (footnotes indenting oddly, e.g.) and I couldn’t see why. I looked at the synched RTF version of the file to see if it formatted oddly there as well. It does not, and so I was good. (I don’t care too much if it looks strange in the window, as long as it doesn’t end up compiling or printing that way.)

At any rate, when I was looking at the synched version of the file, I decided to see how the synching process works. I introduced a very small change into the document. (I added a hyphen in the title.) I then opened up Scrivener and allowed it to update the document from the synched version. The end result? All of my comments and footnotes disappeared!! Fortunately I could roll it back and recover the notes, but it was a bit frightening at first!

I duplicated this once more on the same document, but when I tried making changes to a different document that one preserved the notes after synching. So, I don’t know if it’s something unusual about this particular file or whether there is something else going on.

Avise anyone?


First, I’m not sure what you mean about footnotes indenting oddly - it’s up to you how footnotes get exported, and you can control their indentations too - see the “Footnotes/Comments” pane of Compile.

Second, what do you mean by syncing? How, exactly, are you syncing? Are you talking about folder sync? If so, what program are you opening the synced file in?

Could it just be that you are using inline footnotes which become inspector footnotes when you sync? (The “Import & Export” pane of the Preferences allows you to determine whether RTF footnotes come in as inline or inspector notes - by default they will be in the inspector.) Try looking in the Footnotes & Comments pane of the inspector to see if they are there - you may just need to change your preferences.

All the best,

No. That isn’t the problem.

These are footnotes that originally appeared in the inspector pane of Scrivener. In Scrivener, some of the footnotes were oddly block indenting. That is, in the inspector pane of Scrivener, the footnote would be indented (for some footnotes and not for others). There was nothing I could do that would make those footnotes appear flush left. It’s not a big deal, really, as long as the compile doesn’t appear that way, but it was visually a bit bothersome.

When I edited the synced file, it was the file in the syncFolder that Scrivener makes and updates each time it exits or opens the project. I’m new to Scrivener, and so I’m just trying out all of these features to see how they work. Well, when I updated that file (using MS Word to edit the RTF file), things went terribly wrong. Now, note that I did not edit the footnotes in any way. I simply added a hyphen to the title to see how this feature worked.

When I reopened Scrivener, it asked me if I wanted Scrivener to update the text files based on the changes to the synced files. I said yes, accepting the default options. Then, when I looked at the file, the inspector footnotes had disappeared. No trace of them. No inline notes either. So then I learned how the roll back feature worked.


You can clean up spurious formatting in the Footnotes/Comments pane by selecting notes and right-clicking on them. There will be an option to reset their formatting to default. To fix them all, click once anywhere in that pane and then use Cmd-A to select them all.

On the other matter, Word should be handling footnotes and comments just fine, it’s one of the few word processors that handles both. Did you check to see if they ended up inline? Scroll through the document and look for red/grey bubbles of text. If so, they are okay. There are two ways to notate in Scrivener. To get them back into the Inspector, use the Format/Convert/ sub-menu to convert inline footnotes and annotations to linked. After doing that, you’ll want to visit the Import & Export preference pane, as suggested above, and make sure your import settings are set the way you prefer to work.

AmberV, your fix for the spurious formatting worked great! I didn’t know about that option. Thanks!

For the other, I didn’t see inline comments anywhere. They had simply disappeared. But I’m hoping that if I stay away from editing any of the files in the syncFolder, I won’t run into this problem again.



You’re welcome! Incidentally you can set what that default formatting is in the Formatting preference pane.

Hmm, well it would be a pity if you had to avoid that feature for this reason, for it definitely should be working. The only cases I know of where it definitely does not is with programs like TextEdit, which not only fail to read footnotes and comments, but also destroy them. What version of Word are you using?